summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-02 12:22:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-02 12:22:07 +0000
commit4ba45c1e1fdfa9afe28666a1a6c18de864ba0bed (patch)
treee7a32645be0dc3258b810f67a05a03eafa59aec8 /dev-python/pythonmagick/files
parentFix --as-needed bug #247304 (diff)
downloadgentoo-2-4ba45c1e1fdfa9afe28666a1a6c18de864ba0bed.tar.gz
gentoo-2-4ba45c1e1fdfa9afe28666a1a6c18de864ba0bed.tar.bz2
gentoo-2-4ba45c1e1fdfa9afe28666a1a6c18de864ba0bed.zip
Added fix for python-2.6, re-use autotools, removed older versions
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pythonmagick/files')
-rw-r--r--dev-python/pythonmagick/files/pythonmagick-0.6-gentoo_misc_fixes.patch23
-rw-r--r--dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch31
2 files changed, 31 insertions, 23 deletions
diff --git a/dev-python/pythonmagick/files/pythonmagick-0.6-gentoo_misc_fixes.patch b/dev-python/pythonmagick/files/pythonmagick-0.6-gentoo_misc_fixes.patch
deleted file mode 100644
index 945511019680..000000000000
--- a/dev-python/pythonmagick/files/pythonmagick-0.6-gentoo_misc_fixes.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- SConstruct.orig 2006-10-18 00:57:28.000000000 +0200
-+++ SConstruct 2006-10-18 00:58:26.000000000 +0200
-@@ -20,16 +20,17 @@
- IM_LIB_PATH='/usr/lib/'
- GD_LIBS=['Magick','Magick++','Wand']
- PYTHON_INCLUDE='/usr/include/python2.4'
-- BOOST_PYTHON_LIB=['libboost_python-gcc']
-- CPP_FLAGS=['-DBOOST_PYTHON_STATIC_LIB','-O2']
-+ BOOST_PYTHON_LIB=['libboost_python']
-+ CPP_FLAGS=['-DBOOST_PYTHON_STATIC_LIB']
-
- # setup the environment
- env=Environment(
- LIBPATH=['./',BOOSTLIBPATH, IM_LIB_PATH],
- CPPPATH=[BOOST, PYTHON_INCLUDE] + IM_INCLUDE_PATH,
-- RPATH=['./',BOOSTLIBPATH],
-+ RPATH=[BOOSTLIBPATH],
- CPPFLAGS=CPP_FLAGS
- )
-+env.SConsignFile()
-
- def fix_includes(target,source,env):
- for t in target:
diff --git a/dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch b/dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch
new file mode 100644
index 000000000000..be31eebb64b2
--- /dev/null
+++ b/dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch
@@ -0,0 +1,31 @@
+diff -Nur PythonMagick-0.8.orig/configure.ac PythonMagick-0.8/configure.ac
+--- PythonMagick-0.8.orig/configure.ac 2009-02-02 11:53:17.965859950 +0000
++++ PythonMagick-0.8/configure.ac 2009-02-02 11:54:04.118583794 +0000
+@@ -17,7 +17,7 @@
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ AC_PROG_LIBTOOL
+-AM_PATH_PYTHON(2.5)
++AM_PATH_PYTHON
+ PKG_PROG_PKG_CONFIG
+
+ # Checks for libraries.
+diff -Nur PythonMagick-0.8.orig/m4/ax_python.m4 PythonMagick-0.8/m4/ax_python.m4
+--- PythonMagick-0.8.orig/m4/ax_python.m4 2009-02-02 11:53:17.965859950 +0000
++++ PythonMagick-0.8/m4/ax_python.m4 2009-02-02 11:53:50.063895989 +0000
+@@ -58,13 +58,13 @@
+ AC_DEFUN([AX_PYTHON],
+ [AC_MSG_CHECKING(for python build information)
+ AC_MSG_RESULT([])
+-for python in python2.5 python2.4 python2.3 python2.2 python2.1 python; do
++for python in python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
+ AC_CHECK_PROGS(PYTHON_BIN, [$python])
+ ax_python_bin=$PYTHON_BIN
+ if test x$ax_python_bin != x; then
+ AC_CHECK_LIB($ax_python_bin, main, ax_python_lib=$ax_python_bin, ax_python_lib=no)
+ AC_CHECK_HEADER([$ax_python_bin/Python.h],
+- [[ax_python_header=`locate $ax_python_bin/Python.h | sed -e s,/Python.h,,`]],
++ [[ax_python_header=`locate $ax_python_bin/Python.h | head -n 1 | sed -e s,/Python.h,,`]],
+ ax_python_header=no)
+ if test $ax_python_lib != no; then
+ if test $ax_python_header != no; then