summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-13 12:09:49 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-13 12:09:49 +0000
commit71c96b71b16a9860b44790da1cd28b8601d32738 (patch)
tree4ebdc287bd428aa05547e48896f4a68a42135722 /dev-python/pyx/pyx-0.10.ebuild
parentKeywording ~amd64 (diff)
downloadgentoo-2-71c96b71b16a9860b44790da1cd28b8601d32738.tar.gz
gentoo-2-71c96b71b16a9860b44790da1cd28b8601d32738.tar.bz2
gentoo-2-71c96b71b16a9860b44790da1cd28b8601d32738.zip
New ebuild for bug 195603.
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-python/pyx/pyx-0.10.ebuild')
-rw-r--r--dev-python/pyx/pyx-0.10.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyx/pyx-0.10.ebuild b/dev-python/pyx/pyx-0.10.ebuild
new file mode 100644
index 000000000000..80acde5aae99
--- /dev/null
+++ b/dev-python/pyx/pyx-0.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.10.ebuild,v 1.1 2007/10/13 12:09:49 genstef Exp $
+
+inherit distutils eutils
+
+MY_P=${P/pyx/PyX}
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="virtual/python
+ virtual/tetex"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS CHANGES INSTALL"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd "${S}/faq"
+ make pdf
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # The manual is not currently done because it needs mkhowto
+ # that's not currently available on our python ebuild
+ insinto /usr/share/doc/${P}/
+ doins faq/pyxfaq.pdf
+ fi
+}