summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-01 00:54:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-01 00:54:54 +0000
commit0e69fe4fcf7709cc7512f9019abaae8874f2dc94 (patch)
treed818addf9a601d5616a92a046507f7795d7dc0e9 /dev-python/quixote
parentDelete older ebuild. (diff)
downloadgentoo-2-0e69fe4fcf7709cc7512f9019abaae8874f2dc94.tar.gz
gentoo-2-0e69fe4fcf7709cc7512f9019abaae8874f2dc94.tar.bz2
gentoo-2-0e69fe4fcf7709cc7512f9019abaae8874f2dc94.zip
Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. Avoid breaking strict-aliasing rules.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/quixote')
-rw-r--r--dev-python/quixote/ChangeLog7
-rw-r--r--dev-python/quixote/quixote-2.6.ebuild22
2 files changed, 21 insertions, 8 deletions
diff --git a/dev-python/quixote/ChangeLog b/dev-python/quixote/ChangeLog
index a7336bdc5f41..54cffe594626 100644
--- a/dev-python/quixote/ChangeLog
+++ b/dev-python/quixote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/quixote
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/quixote/ChangeLog,v 1.31 2010/11/01 00:49:25 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/quixote/ChangeLog,v 1.32 2010/11/01 00:54:54 arfrever Exp $
+
+ 01 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ quixote-2.6.ebuild:
+ Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. Avoid breaking
+ strict-aliasing rules.
01 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-quixote-0.6.1.ebuild:
diff --git a/dev-python/quixote/quixote-2.6.ebuild b/dev-python/quixote/quixote-2.6.ebuild
index 951876eb9e34..1a5d81d2bf01 100644
--- a/dev-python/quixote/quixote-2.6.ebuild
+++ b/dev-python/quixote/quixote-2.6.ebuild
@@ -1,12 +1,17 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/quixote/quixote-2.6.ebuild,v 1.6 2010/01/07 21:54:49 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/quixote/quixote-2.6.ebuild,v 1.7 2010/11/01 00:54:54 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-MY_P=${P/q/Q}
+MY_P="${P/q/Q}"
-DESCRIPTION="Python HTML templating framework for developing web applications."
+DESCRIPTION="Python HTML templating framework for developing web applications"
HOMEPAGE="http://quixote.ca"
SRC_URI="http://quixote.ca/releases/${MY_P}.tar.gz"
@@ -15,13 +20,16 @@ SLOT="0"
KEYWORDS="amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
-DEPEND=">=dev-lang/python-2.3"
+DEPEND=""
+RDEPEND=""
S="${WORKDIR}"/${MY_P}
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="ACKS.txt CHANGES.txt doc/*.txt"
+
src_install() {
- DOCS="ACKS.txt CHANGES.txt"
distutils_src_install
- dodoc doc/*.txt
- dohtml doc/*.html
+ dohtml doc/*.html || die "dohtml failed"
}