summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-23 08:27:32 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-23 08:27:32 +0000
commitd897eba82eaacd1da1d001bc8adf341781343d25 (patch)
tree36728559a29939f007449a3d5fbbe80c70c52e7c /dev-python/restkit
parentpunt wrt #508452 (diff)
downloadgentoo-2-d897eba82eaacd1da1d001bc8adf341781343d25.tar.gz
gentoo-2-d897eba82eaacd1da1d001bc8adf341781343d25.tar.bz2
gentoo-2-d897eba82eaacd1da1d001bc8adf341781343d25.zip
bump; pypy2_0 dropped, keywords ppc ppc64 dropped (to appease ipython), general upgrade
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/restkit')
-rw-r--r--dev-python/restkit/ChangeLog10
-rw-r--r--dev-python/restkit/restkit-2.1.4.ebuild58
-rw-r--r--dev-python/restkit/restkit-2.2.3.ebuild55
-rw-r--r--dev-python/restkit/restkit-2.3.3.ebuild61
-rw-r--r--dev-python/restkit/restkit-3.0.2.ebuild54
-rw-r--r--dev-python/restkit/restkit-4.2.1-r1.ebuild3
-rw-r--r--dev-python/restkit/restkit-4.2.2.ebuild49
7 files changed, 60 insertions, 230 deletions
diff --git a/dev-python/restkit/ChangeLog b/dev-python/restkit/ChangeLog
index 4e8197c6dac5..9dc6f62d1116 100644
--- a/dev-python/restkit/ChangeLog
+++ b/dev-python/restkit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/restkit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.15 2014/03/31 21:13:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.16 2014/04/23 08:27:32 idella4 Exp $
+
+*restkit-4.2.2 (23 Apr 2014)
+
+ 23 Apr 2014; Ian Delaney <idella4@gentoo.org> +restkit-4.2.2.ebuild,
+ -restkit-2.1.4.ebuild, -restkit-2.2.3.ebuild, -restkit-2.3.3.ebuild,
+ -restkit-3.0.2.ebuild, restkit-4.2.1-r1.ebuild:
+ bump; pypy2_0 dropped, keywords ppc ppc64 dropped (to appease ipython),
+ general upgrade
31 Mar 2014; Michał Górny <mgorny@gentoo.org> restkit-4.2.1-r1.ebuild:
Add support for the new PyPy slotting.
diff --git a/dev-python/restkit/restkit-2.1.4.ebuild b/dev-python/restkit/restkit-2.1.4.ebuild
deleted file mode 100644
index d15fb28ad85c..000000000000
--- a/dev-python/restkit/restkit-2.1.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-2.1.4.ebuild,v 1.2 2010/10/17 21:57:10 arfrever Exp $
-
-EAPI=3
-
-# tests currently broken
-#DISTUTILS_SRC_TEST="nosetests"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3*"
-
-inherit distutils
-
-TAG="benoitc-restkit-addf4be"
-
-DESCRIPTION="A HTTP ressource kit for Python."
-HOMEPAGE="http://github.com/benoitc/restkit http://benoitc.github.com/restkit/ http://pypi.python.org/pypi/restkit"
-SRC_URI="http://github.com/benoitc/restkit/tarball/${PV}/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+cli doc examples"
-
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx
- dev-python/epydoc )"
-RDEPEND="cli? ( dev-python/ipython
- dev-python/setuptools )"
-
-DOCS="NOTICE README.rst TODO.txt doc/*.rst"
-
-S="${WORKDIR}/${TAG}"
-
-# TODO
-# - optionally depend on gevent and/or eventlet
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- cd doc
- emake html || die "building docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- use cli || rm "${D}"/usr/bin/restcli*
-
- use doc && dohtml -r doc/_build/html/*
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/restkit/restkit-2.2.3.ebuild b/dev-python/restkit/restkit-2.2.3.ebuild
deleted file mode 100644
index a663ab68fe0a..000000000000
--- a/dev-python/restkit/restkit-2.2.3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-2.2.3.ebuild,v 1.2 2010/11/15 15:59:09 arfrever Exp $
-
-EAPI=3
-
-# tests currently broken
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3*"
-
-inherit distutils
-
-DESCRIPTION="A HTTP ressource kit for Python."
-HOMEPAGE="http://github.com/benoitc/restkit http://benoitc.github.com/restkit/ http://pypi.python.org/pypi/restkit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+cli doc examples"
-
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx
- dev-python/epydoc )
- test? ( dev-python/webob )"
-RDEPEND="cli? ( dev-python/ipython
- dev-python/setuptools )"
-
-DOCS="NOTICE README.rst TODO.txt doc/*.rst"
-
-# TODO
-# - optionally depend on gevent and/or eventlet
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- cd doc
- PYTHONPATH="${S}" emake html || die "building docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- use cli || rm "${D}"/usr/bin/restcli*
-
- use doc && dohtml -r doc/_build/html/*
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/restkit/restkit-2.3.3.ebuild b/dev-python/restkit/restkit-2.3.3.ebuild
deleted file mode 100644
index 79e357dcc790..000000000000
--- a/dev-python/restkit/restkit-2.3.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-2.3.3.ebuild,v 1.1 2011/01/11 08:16:45 dev-zero Exp $
-
-EAPI=3
-
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3*"
-
-inherit distutils
-
-DESCRIPTION="A HTTP ressource kit for Python."
-HOMEPAGE="http://github.com/benoitc/restkit http://benoitc.github.com/restkit/ http://pypi.python.org/pypi/restkit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+cli doc examples"
-
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx
- dev-python/epydoc )
- test? ( dev-python/webob )"
-RDEPEND="cli? ( dev-python/ipython
- dev-python/setuptools )"
-
-DOCS="NOTICE README.rst TODO.txt doc/*.rst"
-
-# TODO
-# - optionally depend on gevent and/or eventlet
-
-src_prepare() {
- # remove failing tests, https://github.com/benoitc/restkit/issues#issue/43
- rm "${S}/tests/010-test-proxies.py"
-
- distutils_src_prepare
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- cd doc
- PYTHONPATH="${S}" emake html || die "building docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- use cli || rm "${D}"/usr/bin/restcli*
-
- use doc && dohtml -r doc/_build/html/*
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/restkit/restkit-3.0.2.ebuild b/dev-python/restkit/restkit-3.0.2.ebuild
deleted file mode 100644
index 70cf1a3f63c3..000000000000
--- a/dev-python/restkit/restkit-3.0.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-3.0.2.ebuild,v 1.2 2011/11/29 20:22:15 floppym Exp $
-
-EAPI=3
-
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit distutils
-
-DESCRIPTION="A HTTP ressource kit for Python."
-HOMEPAGE="http://github.com/benoitc/restkit http://benoitc.github.com/restkit/ http://pypi.python.org/pypi/restkit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+cli doc examples"
-
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx
- dev-python/epydoc )
- test? ( dev-python/webob )"
-RDEPEND="cli? ( dev-python/ipython
- dev-python/setuptools )"
-
-DOCS="NOTICE README.rst TODO.txt doc/*.rst"
-
-# TODO
-# - optionally depend on gevent and/or eventlet
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- cd doc
- PYTHONPATH="${S}" emake html || die "building docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- use cli || rm "${D}"/usr/bin/restcli*
-
- use doc && dohtml -r doc/_build/html/*
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/restkit/restkit-4.2.1-r1.ebuild b/dev-python/restkit/restkit-4.2.1-r1.ebuild
index 30064d93ece1..3d0b6447d34b 100644
--- a/dev-python/restkit/restkit-4.2.1-r1.ebuild
+++ b/dev-python/restkit/restkit-4.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.1-r1.ebuild,v 1.6 2014/03/31 21:13:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.1-r1.ebuild,v 1.7 2014/04/23 08:27:32 idella4 Exp $
EAPI=5
@@ -51,4 +51,5 @@ python_install_all() {
insinto /usr/share/doc/${PF}
doins -r examples
fi
+ distutils-r1_python_install_all
}
diff --git a/dev-python/restkit/restkit-4.2.2.ebuild b/dev-python/restkit/restkit-4.2.2.ebuild
new file mode 100644
index 000000000000..35b3f6f6c579
--- /dev/null
+++ b/dev-python/restkit/restkit-4.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.2.ebuild,v 1.1 2014/04/23 08:27:32 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A HTTP ressource kit for Python."
+HOMEPAGE="http://github.com/benoitc/restkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+cli doc examples test"
+
+PY27_USEDEP="$(python_gen_usedep 'python2*')"
+RDEPEND="cli? ( dev-python/ipython[${PY27_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}] )
+ dev-python/webob[${PYTHON_USEDEP}]
+ >=dev-python/socketpool-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/http-parser-0.8.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/epydoc[${PY27_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc ; then
+ pushd doc > /dev/null
+ emake html
+ popd > /dev/null
+ fi
+}
+
+python_test() {
+ nosetests tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use cli || rm "${D}"/usr/bin/restcli* || die
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}