summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-09-27 07:34:16 +0000
committerAli Polatel <hawking@gentoo.org>2007-09-27 07:34:16 +0000
commit34a00fffb0e3a43f18d5def51a27f4e01b0ce25c (patch)
treebebd21dd2bbeee771bbf5015d033060f16d151fc /dev-python/rpy
parentVersion bump: bug 193737 (diff)
downloadgentoo-2-34a00fffb0e3a43f18d5def51a27f4e01b0ce25c.tar.gz
gentoo-2-34a00fffb0e3a43f18d5def51a27f4e01b0ce25c.tar.bz2
gentoo-2-34a00fffb0e3a43f18d5def51a27f4e01b0ce25c.zip
revbump. fix lapack linking issue, bug 143396. added examples use flag. added trailing slash to HOMEPAGE URI. drop old.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-python/rpy')
-rw-r--r--dev-python/rpy/ChangeLog9
-rw-r--r--dev-python/rpy/files/digest-rpy-0.99.2-r1 (renamed from dev-python/rpy/files/digest-rpy-0.99.2)0
-rw-r--r--dev-python/rpy/rpy-0.99.2-r1.ebuild53
-rw-r--r--dev-python/rpy/rpy-0.99.2.ebuild34
4 files changed, 61 insertions, 35 deletions
diff --git a/dev-python/rpy/ChangeLog b/dev-python/rpy/ChangeLog
index aa2986349dfd..522efdb0c620 100644
--- a/dev-python/rpy/ChangeLog
+++ b/dev-python/rpy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/rpy
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.16 2007/04/09 14:12:15 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.17 2007/09/27 07:34:16 hawking Exp $
+
+*rpy-0.99.2-r1 (27 Sep 2007)
+
+ 27 Sep 2007; Ali Polatel <hawking@gentoo.org> -rpy-0.99.2.ebuild,
+ +rpy-0.99.2-r1.ebuild:
+ revbump. fix lapack linking issue, bug 143396. added examples use flag.
+ added trailing slash to HOMEPAGE URI. drop old.
09 Apr 2007; Lukasz Strzygowski <lucass@gentoo.org> rpy-0.4.6.ebuild,
rpy-0.99.2.ebuild:
diff --git a/dev-python/rpy/files/digest-rpy-0.99.2 b/dev-python/rpy/files/digest-rpy-0.99.2-r1
index 86c714b101b3..86c714b101b3 100644
--- a/dev-python/rpy/files/digest-rpy-0.99.2
+++ b/dev-python/rpy/files/digest-rpy-0.99.2-r1
diff --git a/dev-python/rpy/rpy-0.99.2-r1.ebuild b/dev-python/rpy/rpy-0.99.2-r1.ebuild
new file mode 100644
index 000000000000..33a57f9cfa1b
--- /dev/null
+++ b/dev-python/rpy/rpy-0.99.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-0.99.2-r1.ebuild,v 1.1 2007/09/27 07:34:16 hawking Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="RPy is a very simple, yet robust, Python interface to the R Programming Language."
+HOMEPAGE="http://rpy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rpy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="examples lapack"
+
+DEPEND="virtual/python
+ >=dev-lang/R-2.3
+ dev-python/numeric
+ lapack? ( virtual/lapack )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ distutils_src_unpack
+
+ # Fix lapack linking issue, bug 143396
+ if use lapack; then
+ sed -i \
+ -e "s:Rlapack:lapack:" \
+ setup.py || die "sed in setup.py failed"
+ else
+ sed -i \
+ -e "s:'Rlapack'::" \
+ setup.py || die "sed in setup.py failed"
+ fi
+
+ epatch "${FILESDIR}/${P}-version-detect.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+
+ # add R libs to ld.so.conf
+ doenvd "${FILESDIR}/90rpy"
+}
+
+pkg_postinst() {
+ env-update
+}
diff --git a/dev-python/rpy/rpy-0.99.2.ebuild b/dev-python/rpy/rpy-0.99.2.ebuild
deleted file mode 100644
index 59f8e38e6320..000000000000
--- a/dev-python/rpy/rpy-0.99.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-0.99.2.ebuild,v 1.3 2007/06/26 02:00:06 mr_bones_ Exp $
-
-inherit distutils
-
-DESCRIPTION="RPy is a very simple, yet robust, Python interface to the R Programming Language."
-HOMEPAGE="http://rpy.sourceforge.net"
-SRC_URI="mirror://sourceforge/rpy/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE=""
-DEPEND="virtual/python
- >=dev-lang/R-2.3
- dev-python/numeric"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch ${FILESDIR}/${P}-version-detect.patch
-
-}
-
-src_install() {
- distutils_src_install
-
- # add R libs to ld.so.conf
- doenvd "${FILESDIR}/90rpy"
-}
-
-pkg_postinst() {
- env-update
-}