summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-30 07:38:42 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-30 07:38:42 +0000
commit59788493c5ec8d8e8da6066f4efeab7cd13290f6 (patch)
tree9a1082694aefab78ae8304db05b7f72b48f0d1d2 /dev-python/shiboken/shiboken-1.1.1.ebuild
parentRemove old. (diff)
downloadgentoo-2-59788493c5ec8d8e8da6066f4efeab7cd13290f6.tar.gz
gentoo-2-59788493c5ec8d8e8da6066f4efeab7cd13290f6.tar.bz2
gentoo-2-59788493c5ec8d8e8da6066f4efeab7cd13290f6.zip
Add fix for prefix, missing rpath for qt4 installation
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/shiboken/shiboken-1.1.1.ebuild')
-rw-r--r--dev-python/shiboken/shiboken-1.1.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/shiboken/shiboken-1.1.1.ebuild b/dev-python/shiboken/shiboken-1.1.1.ebuild
index 723e61516da2..098e47b1ad85 100644
--- a/dev-python/shiboken/shiboken-1.1.1.ebuild
+++ b/dev-python/shiboken/shiboken-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.1.ebuild,v 1.2 2012/05/29 15:41:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.1.ebuild,v 1.3 2012/05/30 07:38:42 jlec Exp $
EAPI=4
@@ -40,6 +40,12 @@ src_prepare() {
# caused by the usage of a different version suffix with python >= 3.2
sed -i -e "/get_config_var('SOABI')/d" \
cmake/Modules/FindPython3InterpWithDebug.cmake || die
+ if use prefix; then
+ cp "${FILESDIR}"/rpath.cmake .
+ sed \
+ -i '1iinclude(rpath.cmake)' \
+ CMakeLists.txt || die
+ fi
}
src_configure() {