summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-10-15 16:20:14 +0000
committerMike Gilbert <floppym@gentoo.org>2014-10-15 16:20:14 +0000
commit7ec98d1e496fa93eb2bfca5de086c267d0f2b06a (patch)
treec140d3cefb5a7fdaa9a40e983dddb856d09e0237 /dev-python/simplejson
parentVersion bump for many bug fixes (diff)
downloadgentoo-2-7ec98d1e496fa93eb2bfca5de086c267d0f2b06a.tar.gz
gentoo-2-7ec98d1e496fa93eb2bfca5de086c267d0f2b06a.tar.bz2
gentoo-2-7ec98d1e496fa93eb2bfca5de086c267d0f2b06a.zip
Use python_is_python3 function.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog5
-rw-r--r--dev-python/simplejson/simplejson-3.6.4.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index a68d23c332d7..4cb603555ef4 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.137 2014/10/07 06:42:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.138 2014/10/15 16:20:14 floppym Exp $
+
+ 15 Oct 2014; Mike Gilbert <floppym@gentoo.org> simplejson-3.6.4.ebuild:
+ Use python_is_python3 function.
*simplejson-3.6.4 (07 Oct 2014)
diff --git a/dev-python/simplejson/simplejson-3.6.4.ebuild b/dev-python/simplejson/simplejson-3.6.4.ebuild
index 4ee7717645cd..d1d6f6901914 100644
--- a/dev-python/simplejson/simplejson-3.6.4.ebuild
+++ b/dev-python/simplejson/simplejson-3.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.6.4.ebuild,v 1.1 2014/10/07 06:42:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.6.4.ebuild,v 1.2 2014/10/15 16:20:14 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -20,7 +20,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DOCS=( README.rst CHANGES.txt )
python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
+ if ! python_is_python3; then
local CFLAGS=${CFLAGS}
append-cflags -fno-strict-aliasing
fi