summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-03-11 16:17:58 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-03-11 16:17:58 +0000
commit8f082fa1d44cfb3a9f23ed3725bc1c9701092188 (patch)
tree6cba7fa09fdad7ed1fc228aa3df9beacd5c2e6c7 /dev-python/simplejson
parentPorted ebuild to EAPI-2. See bug #266839. (diff)
downloadgentoo-2-8f082fa1d44cfb3a9f23ed3725bc1c9701092188.tar.gz
gentoo-2-8f082fa1d44cfb3a9f23ed3725bc1c9701092188.tar.bz2
gentoo-2-8f082fa1d44cfb3a9f23ed3725bc1c9701092188.zip
Version bump dev-python/simplejson to 2.1.0.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog9
-rw-r--r--dev-python/simplejson/simplejson-2.1.0.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 6a8402e6c17b..7e580cf08bbb 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.20 2009/12/20 10:47:44 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.21 2010/03/11 16:17:58 djc Exp $
+
+*simplejson-2.1.0 (11 Mar 2010)
+
+ 11 Mar 2010; Dirkjan Ochtman <djc@gentoo.org> +simplejson-2.1.0.ebuild:
+ Version bump to 2.1.0.
20 Dec 2009; Fabian Groffen <grobian@gentoo.org>
simplejson-2.0.9-r1.ebuild:
diff --git a/dev-python/simplejson/simplejson-2.1.0.ebuild b/dev-python/simplejson/simplejson-2.1.0.ebuild
new file mode 100644
index 000000000000..433e5852aba2
--- /dev/null
+++ b/dev-python/simplejson/simplejson-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.1.0.ebuild,v 1.1 2010/03/11 16:17:58 djc Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DESCRIPTION="A simple, fast, complete, correct and extensible JSON encoder and decoder."
+HOMEPAGE="http://undefined.org/python/#simplejson"
+SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
+# failures reported as http://code.google.com/p/simplejson/issues/detail?id=73
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" simplejson/tests/__init__.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ fi
+}