summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-01 15:43:50 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-01 15:43:50 +0000
commitddd8c2b09f8037f46c7f008e26a2ccea81bac012 (patch)
treebdd2ad7f42e1f219a8a4176735eb2f0b15a7e4a1 /dev-python/sip
parent[QA] Remove obsolete googleearth mask from 64bit-native feature. (diff)
downloadgentoo-2-ddd8c2b09f8037f46c7f008e26a2ccea81bac012.tar.gz
gentoo-2-ddd8c2b09f8037f46c7f008e26a2ccea81bac012.tar.bz2
gentoo-2-ddd8c2b09f8037f46c7f008e26a2ccea81bac012.zip
Add re-base of darwin patch
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog6
-rw-r--r--dev-python/sip/files/sip-4.15.5-darwin.patch30
-rw-r--r--dev-python/sip/sip-4.15.5.ebuild4
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 8e531a7ad783..e652aa3f1bab 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.280 2014/04/01 08:07:06 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.281 2014/04/01 15:43:49 idella4 Exp $
+
+ 01 Apr 2014; Ian Delaney <idella4@gentoo.org> +files/sip-4.15.5-darwin.patch,
+ sip-4.15.5.ebuild:
+ Add re-base of darwin patch
*sip-4.15.5 (01 Apr 2014)
diff --git a/dev-python/sip/files/sip-4.15.5-darwin.patch b/dev-python/sip/files/sip-4.15.5-darwin.patch
new file mode 100644
index 000000000000..b625d15c27c5
--- /dev/null
+++ b/dev-python/sip/files/sip-4.15.5-darwin.patch
@@ -0,0 +1,30 @@
+diff -ur sip-4.15.5.orig/siputils.py sip-4.15.5/siputils.py
+--- siputils.py 2014-02-21 18:31:35.000000000 +0800
++++ siputils.py 2014-04-01 23:21:41.895036589 +0800
+@@ -945,8 +945,6 @@
+ """
+ if self.generator in ("MSVC", "MSVC.NET", "MSBUILD", "BMAKE"):
+ plib = clib + ".lib"
+- elif sys.platform == "darwin" and framework:
+- plib = "-framework " + clib
+ else:
+ plib = "-l" + clib
+
+@@ -961,8 +959,6 @@
+ """
+ if self.generator in ("MSVC", "MSVC.NET", "MSBUILD", "BMAKE"):
+ prl_name = os.path.join(self.config.qt_lib_dir, clib + ".prl")
+- elif sys.platform == "darwin" and framework:
+- prl_name = os.path.join(self.config.qt_lib_dir, clib + ".framework", clib + ".prl")
+ else:
+ prl_name = os.path.join(self.config.qt_lib_dir, "lib" + clib + ".prl")
+
+@@ -1633,7 +1629,7 @@
+ if sys.platform == "win32":
+ ext = "pyd"
+ elif sys.platform == "darwin":
+- ext = "so"
++ ext = "bundle"
+ elif sys.platform == "cygwin":
+ ext = "dll"
+ else:
diff --git a/dev-python/sip/sip-4.15.5.ebuild b/dev-python/sip/sip-4.15.5.ebuild
index 425ef0283a87..ccb10bcf4106 100644
--- a/dev-python/sip/sip-4.15.5.ebuild
+++ b/dev-python/sip/sip-4.15.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.15.5.ebuild,v 1.1 2014/04/01 08:07:06 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.15.5.ebuild,v 1.2 2014/04/01 15:43:49 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -44,7 +44,7 @@ RDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_prepare() {
-# epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
+ epatch "${FILESDIR}"/${PN}-4.15.5-darwin.patch
if [[ ${PV} == *9999* ]]; then
python2 build.py prepare || die