summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-01-31 12:14:01 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-01-31 12:14:01 +0000
commit3009dfa73b4c24b283e489cdbd38533f90d4c076 (patch)
treef84120ac002bf31ac255b6dd693623301d1e84cb /dev-python/south
parentsys-kernel/genkernel: Bump to 3.4.12.6 (diff)
downloadgentoo-2-3009dfa73b4c24b283e489cdbd38533f90d4c076.tar.gz
gentoo-2-3009dfa73b4c24b283e489cdbd38533f90d4c076.tar.bz2
gentoo-2-3009dfa73b4c24b283e489cdbd38533f90d4c076.zip
Version bump south to 0.7.3 (bug 347581).
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/south')
-rw-r--r--dev-python/south/ChangeLog9
-rw-r--r--dev-python/south/south-0.7.3.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/south/ChangeLog b/dev-python/south/ChangeLog
index 0d06044088ee..1f3610ef4c7c 100644
--- a/dev-python/south/ChangeLog
+++ b/dev-python/south/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/south
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/ChangeLog,v 1.1 2010/08/27 17:27:31 dev-zero Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/ChangeLog,v 1.2 2011/01/31 12:14:01 djc Exp $
+
+*south-0.7.3 (31 Jan 2011)
+
+ 31 Jan 2011; Dirkjan Ochtman <djc@gentoo.org> +south-0.7.3.ebuild:
+ Version bump to 0.7.3 (bug 347581).
*south-0.7.2 (27 Aug 2010)
diff --git a/dev-python/south/south-0.7.3.ebuild b/dev-python/south/south-0.7.3.ebuild
new file mode 100644
index 000000000000..1feb3e4fac9d
--- /dev/null
+++ b/dev-python/south/south-0.7.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.7.3.ebuild,v 1.1 2011/01/31 12:14:01 djc Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Intelligent schema migrations for Django apps."
+HOMEPAGE="http://south.aeracode.org/"
+SRC_URI="http://www.aeracode.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="dev-python/django"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C docs html || die "building docs failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r docs/_build/html/*
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog "In order to use the south schema migrations for your Django project,"
+ elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
+ elog "manage.py will now automagically offer the new functions."
+}