summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-06 01:51:10 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-06 01:51:10 +0000
commit84fa42eb48b8911711455f51de1e83f5e5a98f6f (patch)
treee65b628df7e979a146ef2b3e960dc393b1288119 /dev-python/sphinx/sphinx-1.0.7.ebuild
parentFix typo in manifest (diff)
downloadgentoo-2-84fa42eb48b8911711455f51de1e83f5e5a98f6f.tar.gz
gentoo-2-84fa42eb48b8911711455f51de1e83f5e5a98f6f.tar.bz2
gentoo-2-84fa42eb48b8911711455f51de1e83f5e5a98f6f.zip
Remove old.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/sphinx/sphinx-1.0.7.ebuild')
-rw-r--r--dev-python/sphinx/sphinx-1.0.7.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/sphinx/sphinx-1.0.7.ebuild b/dev-python/sphinx/sphinx-1.0.7.ebuild
deleted file mode 100644
index d3d34789abb8..000000000000
--- a/dev-python/sphinx/sphinx-1.0.7.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0.7.ebuild,v 1.11 2012/03/10 17:50:10 jlec Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc latex"
-
-DEPEND=">=dev-python/docutils-0.5
- >=dev-python/jinja-2.2
- >=dev-python/pygments-0.8
- dev-python/setuptools
- latex? ( dev-texlive/texlive-latexextra )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- pushd doc > /dev/null
- einfo "Generation of documentation"
- PYTHONPATH=".." emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "Installation of documentation failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generate the Grammar pickle to avoid sandbox violations.
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "import sys; sys.path.insert(0, '${EROOT}$(python_get_sitedir -b)'); from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${EROOT}$(python_get_sitedir -b)/sphinx/pycode/Grammar.txt')"
- }
- python_execute_function \
- --action-message 'Generation of Grammar pickle with $(python_get_implementation_and_version)...' \
- --failure-message 'Generation of Grammar pickle with $(python_get_implementation_and_version) failed' \
- generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm -f "${EROOT}$(python_get_sitedir -b)/sphinx/pycode"/Grammar*.pickle || return 1
-
- # Delete empty parent directories.
- local dir="${EROOT}$(python_get_sitedir -b)/sphinx/pycode"
- while [[ "${dir}" != "${EROOT%/}" ]]; do
- rmdir "${dir}" 2> /dev/null || break
- dir="${dir%/*}"
- done
- }
- python_execute_function \
- --action-message 'Deletion of Grammar pickle with $(python_get_implementation_and_version)...' \
- --failure-message 'Deletion of Grammar pickle with $(python_get_implementation_and_version) failed' \
- deletion_of_grammar_pickle
-}