summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-10-10 07:06:50 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-10-10 07:06:50 +0000
commit2437357a75aa6d7c0768a2983bec82ae8adc62b5 (patch)
tree6af8400f11ae24070fe96fb451a0450c1785f356 /dev-python/sphinx
parent*portage-2.2.0_alpha65 (10 Oct 2011) (diff)
downloadgentoo-2-2437357a75aa6d7c0768a2983bec82ae8adc62b5.tar.gz
gentoo-2-2437357a75aa6d7c0768a2983bec82ae8adc62b5.tar.bz2
gentoo-2-2437357a75aa6d7c0768a2983bec82ae8adc62b5.zip
Version bump sphinx to 1.1.
(Portage version: 2.1.10.20/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/ChangeLog7
-rw-r--r--dev-python/sphinx/sphinx-1.1.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/dev-python/sphinx/ChangeLog b/dev-python/sphinx/ChangeLog
index 3f9c8e9b5b99..56a9a02c912e 100644
--- a/dev-python/sphinx/ChangeLog
+++ b/dev-python/sphinx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sphinx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.92 2011/04/04 11:50:00 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.93 2011/10/10 07:06:50 djc Exp $
+
+*sphinx-1.1 (10 Oct 2011)
+
+ 10 Oct 2011; Dirkjan Ochtman <djc@gentoo.org> +sphinx-1.1.ebuild:
+ Version bump to 1.1.
04 Apr 2011; Dirkjan Ochtman <djc@gentoo.org> -sphinx-1.0.4.ebuild,
-sphinx-1.0.5.ebuild, -sphinx-1.0.6.ebuild:
diff --git a/dev-python/sphinx/sphinx-1.1.ebuild b/dev-python/sphinx/sphinx-1.1.ebuild
new file mode 100644
index 000000000000..75fcefa32c17
--- /dev/null
+++ b/dev-python/sphinx/sphinx-1.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.1.ebuild,v 1.1 2011/10/10 07:06:50 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Sphinx"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python documentation generator"
+HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc latex"
+
+RDEPEND=">=dev-python/docutils-0.7
+ >=dev-python/jinja-2.3
+ >=dev-python/pygments-1.2
+ latex? ( dev-texlive/texlive-latexextra )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ pushd doc > /dev/null
+ einfo "Generation of documentation"
+ PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -A txt -r doc/_build/html/* || die "Installation of documentation failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Generate the Grammar pickle to avoid sandbox violations.
+ generation_of_grammar_pickle() {
+ "$(PYTHON)" -c "import sys; sys.path.insert(0, '${EROOT}$(python_get_sitedir -b)'); from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${EROOT}$(python_get_sitedir -b)/sphinx/pycode/Grammar.txt')"
+ }
+ python_execute_function \
+ --action-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
+ --failure-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
+ generation_of_grammar_pickle
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+
+ deletion_of_grammar_pickle() {
+ rm -f "${EROOT}$(python_get_sitedir -b)/sphinx/pycode"/Grammar*.pickle || return 1
+
+ # Delete empty parent directories.
+ local dir="${EROOT}$(python_get_sitedir -b)/sphinx/pycode"
+ while [[ "${dir}" != "${EROOT%/}" ]]; do
+ rmdir "${dir}" 2> /dev/null || break
+ dir="${dir%/*}"
+ done
+ }
+ python_execute_function \
+ --action-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
+ --failure-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
+ deletion_of_grammar_pickle
+}