summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-03-02 08:39:17 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-03-02 08:39:17 +0000
commit793fd46b52c2950366bac863ff63c5eae2e6ff28 (patch)
tree57f2db936f31d4ceee24a3ba1ce5928222bc3824 /dev-python/sphinx
parentx86 stable wrt bug #306711 (diff)
downloadgentoo-2-793fd46b52c2950366bac863ff63c5eae2e6ff28.tar.gz
gentoo-2-793fd46b52c2950366bac863ff63c5eae2e6ff28.tar.bz2
gentoo-2-793fd46b52c2950366bac863ff63c5eae2e6ff28.zip
Version bump dev-python/sphinx to 0.6.5.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/ChangeLog7
-rw-r--r--dev-python/sphinx/sphinx-0.6.5.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-python/sphinx/ChangeLog b/dev-python/sphinx/ChangeLog
index 55ae942d62b8..935d43caa8bb 100644
--- a/dev-python/sphinx/ChangeLog
+++ b/dev-python/sphinx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sphinx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.42 2010/03/02 02:44:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.43 2010/03/02 08:39:17 djc Exp $
+
+*sphinx-0.6.5 (02 Mar 2010)
+
+ 02 Mar 2010; Dirkjan Ochtman <djc@gentoo.org> +sphinx-0.6.5.ebuild:
+ Version bump to 0.6.5.
02 Mar 2010; Jeroen Roovers <jer@gentoo.org> sphinx-0.6.4.ebuild:
Stable for HPPA (bug #305185).
diff --git a/dev-python/sphinx/sphinx-0.6.5.ebuild b/dev-python/sphinx/sphinx-0.6.5.ebuild
new file mode 100644
index 000000000000..38df9de3a3c8
--- /dev/null
+++ b/dev-python/sphinx/sphinx-0.6.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.5.ebuild,v 1.1 2010/03/02 08:39:17 djc Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Sphinx"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool to create documentation for Python projects"
+HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="doc test latex"
+
+RDEPEND=">=dev-python/pygments-0.8
+ >=dev-python/jinja2-2.1
+ >=dev-python/docutils-0.4
+ latex? ( dev-texlive/texlive-latexextra )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd doc
+ PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -A txt -r doc/_build/html/* || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
+ generation_of_grammar_pickle() {
+ "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" \
+ || die "Generation of grammar pickle failed"
+ }
+ python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+
+ deletion_of_grammar_pickle() {
+ rm "${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode"/Grammar*.pickle
+ }
+ python_execute_function --action-message 'Deletion of Grammar pickle with Python ${PYTHON_ABI}...' deletion_of_grammar_pickle
+}