summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-18 11:12:00 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-18 11:12:00 +0000
commit7f840f7e4099d2af2fcf1a0bee931c8dcd3838b2 (patch)
tree1e1975e4cc29bcd11c5e6bafff6470231b9666fa /dev-python/sphinx
parentEnable python3.3. (diff)
downloadgentoo-2-7f840f7e4099d2af2fcf1a0bee931c8dcd3838b2.tar.gz
gentoo-2-7f840f7e4099d2af2fcf1a0bee931c8dcd3838b2.tar.bz2
gentoo-2-7f840f7e4099d2af2fcf1a0bee931c8dcd3838b2.zip
Enable python3.3. Properly die on test failure.
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/ChangeLog5
-rw-r--r--dev-python/sphinx/sphinx-1.1.3-r5.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/sphinx/ChangeLog b/dev-python/sphinx/ChangeLog
index b7b5e3b7fc3e..5f81e949d25e 100644
--- a/dev-python/sphinx/ChangeLog
+++ b/dev-python/sphinx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/sphinx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.124 2013/01/15 21:50:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.125 2013/01/18 11:12:00 mgorny Exp $
+
+ 18 Jan 2013; Michał Górny <mgorny@gentoo.org> sphinx-1.1.3-r5.ebuild:
+ Enable python3.3. Properly die on test failure.
15 Jan 2013; Michał Górny <mgorny@gentoo.org> sphinx-1.1.3-r5.ebuild:
Improve grammar. Thanks to radhermit.
diff --git a/dev-python/sphinx/sphinx-1.1.3-r5.ebuild b/dev-python/sphinx/sphinx-1.1.3-r5.ebuild
index 5475fd0921a8..a593cb9aa182 100644
--- a/dev-python/sphinx/sphinx-1.1.3-r5.ebuild
+++ b/dev-python/sphinx/sphinx-1.1.3-r5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.1.3-r5.ebuild,v 1.2 2013/01/15 21:50:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.1.3-r5.ebuild,v 1.3 2013/01/18 11:12:00 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} pypy1_9 )
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy1_9 )
inherit distutils-r1 versionator
@@ -62,7 +62,8 @@ python_compile_all() {
}
python_test() {
- nosetests -w "${BUILD_DIR}"/lib/tests || ewarn "Tests fail with ${EPYTHON}"
+ nosetests -w "${BUILD_DIR}"/lib/tests \
+ || die "Tests fail with ${EPYTHON}"
}
python_install_all() {