summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-10-21 02:33:16 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-10-21 02:33:16 +0000
commit4ae4555477e63cac55db056a42a3c6807075f15b (patch)
tree252180205b624eadefd6bac3ceb4252987e5a2d6 /dev-python/sphinxcontrib-cheeseshop
parentAdd live ebuild for 0.9.33 branch, bug #510082 (diff)
downloadgentoo-2-4ae4555477e63cac55db056a42a3c6807075f15b.tar.gz
gentoo-2-4ae4555477e63cac55db056a42a3c6807075f15b.tar.bz2
gentoo-2-4ae4555477e63cac55db056a42a3c6807075f15b.zip
add ebuild for sphinxcontrib-cheeseshop—dependence for fig
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/sphinxcontrib-cheeseshop')
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/ChangeLog10
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/metadata.xml10
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild32
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-cheeseshop/ChangeLog b/dev-python/sphinxcontrib-cheeseshop/ChangeLog
new file mode 100644
index 000000000000..cf33afc28484
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/sphinxcontrib-cheeseshop
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinxcontrib-cheeseshop/ChangeLog,v 1.1 2014/10/21 02:33:16 alunduil Exp $
+
+*sphinxcontrib-cheeseshop-0.2 (21 Oct 2014)
+
+ 21 Oct 2014; Alex Brandt <alunduil@gentoo.org>
+ +sphinxcontrib-cheeseshop-0.2.ebuild, +metadata.xml:
+ add ebuild written by me
+
diff --git a/dev-python/sphinxcontrib-cheeseshop/metadata.xml b/dev-python/sphinxcontrib-cheeseshop/metadata.xml
new file mode 100644
index 000000000000..02be8c5eb78f
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild
new file mode 100644
index 000000000000..656cc747fb22
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild,v 1.1 2014/10/21 02:33:16 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension cheeseshop"
+HOMEPAGE="http://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ ebegin 'patching setup.py'
+ sed \
+ -e '5s/file/open/' \
+ -i setup.py
+ STATUS=$?
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}