summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-12-15 01:51:46 +0000
committerMike Gilbert <floppym@gentoo.org>2013-12-15 01:51:46 +0000
commit292cc9c8f772012c46f8b9b3ccb60fd471b933a6 (patch)
tree69faf4d1a0080ab21d679bd052b6df1d5e186465 /dev-python/subunit
parentBump. (diff)
downloadgentoo-2-292cc9c8f772012c46f8b9b3ccb60fd471b933a6.tar.gz
gentoo-2-292cc9c8f772012c46f8b9b3ccb60fd471b933a6.tar.bz2
gentoo-2-292cc9c8f772012c46f8b9b3ccb60fd471b933a6.zip
Adjust dependency on testtools, and make the tests work.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog5
-rw-r--r--dev-python/subunit/subunit-0.0.16.ebuild12
2 files changed, 14 insertions, 3 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 1abcdbd310d1..7941b5fe4215 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.35 2013/12/11 02:33:29 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.36 2013/12/15 01:51:46 floppym Exp $
+
+ 15 Dec 2013; Mike Gilbert <floppym@gentoo.org> subunit-0.0.16.ebuild:
+ Adjust dependency on testtools, and make the tests work.
*subunit-0.0.16 (11 Dec 2013)
*subunit-0.0.15-r1 (11 Dec 2013)
diff --git a/dev-python/subunit/subunit-0.0.16.ebuild b/dev-python/subunit/subunit-0.0.16.ebuild
index 45d7b6a45c1f..35c954cd64fa 100644
--- a/dev-python/subunit/subunit-0.0.16.ebuild
+++ b/dev-python/subunit/subunit-0.0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.16.ebuild,v 1.1 2013/12/11 02:33:29 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.16.ebuild,v 1.2 2013/12/15 01:51:46 floppym Exp $
EAPI=5
@@ -19,7 +19,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
#ia64 s390 sh sparc amd64-fbsd
IUSE=""
-RDEPEND=">=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
dev-python/extras[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -28,6 +28,8 @@ DEPEND="${RDEPEND}
dev-util/cppunit
virtual/pkgconfig"
+DISTUTILS_IN_SOURCE_BUILD=1
+
src_configure() {
econf
distutils-r1_src_configure
@@ -38,6 +40,12 @@ src_compile() {
distutils-r1_src_compile
}
+python_test() {
+ local -x PATH="${PWD}/shell/share:${PATH}"
+ local -x PYTHONPATH=python
+ "${PYTHON}" -m testtools.run all_tests.test_suite || die "Testing failed with ${EPYTHON}"
+}
+
src_install() {
local targets=(
install-include_subunitHEADERS