summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-24 18:22:26 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-24 18:22:26 +0000
commit7e6ed4da55dd05513f88b88855acfa30c90d5d85 (patch)
treec308ab0fd9dd676fa6d6bd01be4d4ea2d35c5515 /dev-python/subunit
parentVersion bump wrt bug #489202, thanks to Mr. Anderson <walch.martin AT web.de> (diff)
downloadgentoo-2-7e6ed4da55dd05513f88b88855acfa30c90d5d85.tar.gz
gentoo-2-7e6ed4da55dd05513f88b88855acfa30c90d5d85.tar.bz2
gentoo-2-7e6ed4da55dd05513f88b88855acfa30c90d5d85.zip
update of subunit to 0.0.15 and added support for normal python-r1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog7
-rw-r--r--dev-python/subunit/subunit-0.0.15.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 149740dae1dc..5ae58c08a9f0 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.27 2013/09/05 18:47:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.28 2013/10/24 18:22:26 prometheanfire Exp $
+
+*subunit-0.0.15 (24 Oct 2013)
+
+ 24 Oct 2013; Matthew Thode <prometheanfire@gentoo.org> +subunit-0.0.15.ebuild:
+ update of subunit to 0.0.15 and added support for normal python-r1
05 Sep 2013; Michał Górny <mgorny@gentoo.org> subunit-0.0.10-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/subunit/subunit-0.0.15.ebuild b/dev-python/subunit/subunit-0.0.15.ebuild
new file mode 100644
index 000000000000..028272262a2f
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.15.ebuild,v 1.1 2013/10/24 18:22:26 prometheanfire Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+#need to keyword the following in =dev-python/extras-0.0.3 then readd the keywords here
+#alpha ia64 s390 sh sparc amd64-fbsd
+IUSE=""
+
+RDEPEND=">=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
+ >=sys-devel/automake-1.12
+ virtual/pkgconfig"
+
+python_test() {
+ "${PYTHON}" runtests.py || die
+}