summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-12 19:20:41 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-12 19:20:41 +0000
commit850479f1095dd45f15078872032f27b137f0e666 (patch)
treef286816fddf06853ad2262479871d62375187d3c /dev-python/subunit
parentx86 stable wrt bug #512516 (diff)
downloadgentoo-2-850479f1095dd45f15078872032f27b137f0e666.tar.gz
gentoo-2-850479f1095dd45f15078872032f27b137f0e666.tar.bz2
gentoo-2-850479f1095dd45f15078872032f27b137f0e666.zip
Enable multilib support, needed for samba-4 and dev-libs/check (bug #510892).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog7
-rw-r--r--dev-python/subunit/subunit-0.0.18-r2.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index b8fbf1f714ea..176f5ced3301 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.45 2014/06/12 07:57:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.46 2014/06/12 19:20:41 mgorny Exp $
+
+*subunit-0.0.18-r2 (12 Jun 2014)
+
+ 12 Jun 2014; Michał Górny <mgorny@gentoo.org> +subunit-0.0.18-r2.ebuild:
+ Enable multilib support, needed for samba-4 and dev-libs/check (bug #510892).
*subunit-0.0.18-r1 (12 Jun 2014)
diff --git a/dev-python/subunit/subunit-0.0.18-r2.ebuild b/dev-python/subunit/subunit-0.0.18-r2.ebuild
new file mode 100644
index 000000000000..e46bdaf06160
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.18-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.18-r2.ebuild,v 1.1 2014/06/12 19:20:41 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1 eutils multilib-minimal
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+#need to keyword the following in =dev-python/extras-0.0.3 then readd the keywords here
+#ia64 s390 sh sparc amd64-fbsd
+IUSE="static-libs"
+
+RDEPEND=">=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]"
+# test? ( dev-python/testscenarios[${PYTHON_USEDEP}] )
+#requires keywording first; Bug #506510
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/perl
+ dev-libs/check[${MULTILIB_USEDEP}]
+ dev-util/cppunit[${MULTILIB_USEDEP}]
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+#requires keywording first; Bug #506510
+RESTRICT="test"
+
+src_prepare() {
+ # needed for perl modules
+ multilib_copy_sources
+ distutils-r1_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+ multilib_is_native_abi && distutils-r1_src_compile
+}
+
+python_test() {
+ local -x PATH="${PWD}/shell/share:${PATH}"
+ local -x PYTHONPATH=python
+ "${PYTHON}" -m testtools.run all_tests.test_suite || die "Testing failed with ${EPYTHON}"
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ local targets=(
+ install-include_subunitHEADERS
+ install-pcdataDATA
+ install-exec-local
+ install-libLTLIBRARIES
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+
+ multilib_is_native_abi && distutils-r1_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}