summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-12-11 02:33:29 +0000
committerMike Gilbert <floppym@gentoo.org>2013-12-11 02:33:29 +0000
commit95284c14a9a16e296cc55f7becaef71b34363978 (patch)
tree25cc32485d53c281a2fbc41e016d6f2d348cbc98 /dev-python/subunit
parentAdd python use flag to IUSE defaults - completely fix bug 489472. (diff)
downloadgentoo-2-95284c14a9a16e296cc55f7becaef71b34363978.tar.gz
gentoo-2-95284c14a9a16e296cc55f7becaef71b34363978.tar.bz2
gentoo-2-95284c14a9a16e296cc55f7becaef71b34363978.zip
Version bump. Switch to a hybrid autotools/distutils install.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog9
-rw-r--r--dev-python/subunit/subunit-0.0.15-r1.ebuild51
-rw-r--r--dev-python/subunit/subunit-0.0.16.ebuild51
3 files changed, 110 insertions, 1 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 748ee9cc958b..1abcdbd310d1 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.34 2013/12/10 04:40:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.35 2013/12/11 02:33:29 floppym Exp $
+
+*subunit-0.0.16 (11 Dec 2013)
+*subunit-0.0.15-r1 (11 Dec 2013)
+
+ 11 Dec 2013; Mike Gilbert <floppym@gentoo.org> +subunit-0.0.15-r1.ebuild,
+ +subunit-0.0.16.ebuild:
+ Version bump. Switch to a hybrid autotools/distutils install.
10 Dec 2013; Ian Delaney <idella4@gentoo.org> subunit-0.0.15.ebuild:
reverted to python-r1, for now
diff --git a/dev-python/subunit/subunit-0.0.15-r1.ebuild b/dev-python/subunit/subunit-0.0.15-r1.ebuild
new file mode 100644
index 000000000000..13c61977c84e
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.15-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.15-r1.ebuild,v 1.1 2013/12/11 02:33:29 floppym Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+#need to keyword the following in =dev-python/extras-0.0.3 then readd the keywords here
+#ia64 s390 sh sparc amd64-fbsd
+IUSE=""
+
+RDEPEND=">=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
+ virtual/pkgconfig"
+
+src_configure() {
+ econf
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ emake
+ distutils-r1_src_compile
+}
+
+src_install() {
+ local targets=(
+ install-include_subunitHEADERS
+ install-pcdataDATA
+ install-exec-local
+ install-libLTLIBRARIES
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+ prune_libtool_files
+ distutils-r1_src_install
+}
diff --git a/dev-python/subunit/subunit-0.0.16.ebuild b/dev-python/subunit/subunit-0.0.16.ebuild
new file mode 100644
index 000000000000..45d7b6a45c1f
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.16.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.16.ebuild,v 1.1 2013/12/11 02:33:29 floppym Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+#need to keyword the following in =dev-python/extras-0.0.3 then readd the keywords here
+#ia64 s390 sh sparc amd64-fbsd
+IUSE=""
+
+RDEPEND=">=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
+ virtual/pkgconfig"
+
+src_configure() {
+ econf
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ emake
+ distutils-r1_src_compile
+}
+
+src_install() {
+ local targets=(
+ install-include_subunitHEADERS
+ install-pcdataDATA
+ install-exec-local
+ install-libLTLIBRARIES
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+ prune_libtool_files
+ distutils-r1_src_install
+}