summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-12 07:57:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-12 07:57:39 +0000
commitbca6dccddc578600ba359b2c648f8c82763b5d47 (patch)
tree415ab66fabb60ae33ede326bf01afb5083c79b25 /dev-python/subunit
parentAdd py34 support (diff)
downloadgentoo-2-bca6dccddc578600ba359b2c648f8c82763b5d47.tar.gz
gentoo-2-bca6dccddc578600ba359b2c648f8c82763b5d47.tar.bz2
gentoo-2-bca6dccddc578600ba359b2c648f8c82763b5d47.zip
Add py34
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog7
-rw-r--r--dev-python/subunit/subunit-0.0.18-r1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 56b3651d6c7e..b8fbf1f714ea 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.44 2014/06/08 09:36:14 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.45 2014/06/12 07:57:39 patrick Exp $
+
+*subunit-0.0.18-r1 (12 Jun 2014)
+
+ 12 Jun 2014; Patrick Lauer <patrick@gentoo.org> +subunit-0.0.18-r1.ebuild:
+ Add py34
08 Jun 2014; Akinori Hattori <hattya@gentoo.org> subunit-0.0.15-r1.ebuild,
subunit-0.0.16.ebuild, subunit-0.0.18.ebuild:
diff --git a/dev-python/subunit/subunit-0.0.18-r1.ebuild b/dev-python/subunit/subunit-0.0.18-r1.ebuild
new file mode 100644
index 000000000000..e43013f8e921
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.18-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.18-r1.ebuild,v 1.1 2014/06/12 07:57:39 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+#need to keyword the following in =dev-python/extras-0.0.3 then readd the keywords here
+#ia64 s390 sh sparc amd64-fbsd
+IUSE="static-libs"
+
+RDEPEND=">=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]"
+# test? ( dev-python/testscenarios[${PYTHON_USEDEP}] )
+#requires keywording first; Bug #506510
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
+ virtual/pkgconfig"
+#requires keywording first; Bug #506510
+RESTRICT="test"
+
+src_configure() {
+ econf --enable-shared $(use_enable static-libs static)
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ emake
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local -x PATH="${PWD}/shell/share:${PATH}"
+ local -x PYTHONPATH=python
+ "${PYTHON}" -m testtools.run all_tests.test_suite || die "Testing failed with ${EPYTHON}"
+}
+
+src_install() {
+ local targets=(
+ install-include_subunitHEADERS
+ install-pcdataDATA
+ install-exec-local
+ install-libLTLIBRARIES
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+ prune_libtool_files
+ distutils-r1_src_install
+}