summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-10 04:12:10 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-10 04:12:10 +0000
commitfb6d6abfa04fd2d7162013cb9a75e2052ab1681a (patch)
tree72b126a8fc587653157b5dda8e0066fb26a5b901 /dev-python/testscenarios
parentBump (diff)
downloadgentoo-2-fb6d6abfa04fd2d7162013cb9a75e2052ab1681a.tar.gz
gentoo-2-fb6d6abfa04fd2d7162013cb9a75e2052ab1681a.tar.bz2
gentoo-2-fb6d6abfa04fd2d7162013cb9a75e2052ab1681a.zip
bump; drop pypy support due to new dep lacking it, upgrade test phase
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/ChangeLog7
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/testscenarios/ChangeLog b/dev-python/testscenarios/ChangeLog
index 89a46f5299bf..ea8cd912462f 100644
--- a/dev-python/testscenarios/ChangeLog
+++ b/dev-python/testscenarios/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testscenarios
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/ChangeLog,v 1.29 2015/06/09 17:15:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/ChangeLog,v 1.30 2015/07/10 04:12:10 idella4 Exp $
+
+*testscenarios-0.5.0 (10 Jul 2015)
+
+ 10 Jul 2015; Ian Delaney <idella4@gentoo.org> +testscenarios-0.5.0.ebuild:
+ bump; drop pypy support due to new dep lacking it, upgrade test phase
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/dev-python/testscenarios/testscenarios-0.5.0.ebuild b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
new file mode 100644
index 000000000000..9ea61733ef72
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/testscenarios-0.5.0.ebuild,v 1.1 2015/07/10 04:12:10 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove a faulty file from tests, missing a required attribute
+ rm ${PN}/tests/test_testcase.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover
+}