summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-04 05:33:06 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-04 05:33:06 +0000
commit48a99acdf174b1c76e5df9f3a91463c3878db0c2 (patch)
tree0e5895f5ea210091a6ad35c2ec577524f8c0de60 /dev-python/testtools
parentSet VALA_MAX_API_VERSION since build fails with vala-0.24 (diff)
downloadgentoo-2-48a99acdf174b1c76e5df9f3a91463c3878db0c2.tar.gz
gentoo-2-48a99acdf174b1c76e5df9f3a91463c3878db0c2.tar.bz2
gentoo-2-48a99acdf174b1c76e5df9f3a91463c3878db0c2.zip
bump, thx for testing by Chicago
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/ChangeLog7
-rw-r--r--dev-python/testtools/testtools-0.9.35.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/testtools/ChangeLog b/dev-python/testtools/ChangeLog
index ce8a5eb1be24..0c4e417bc77c 100644
--- a/dev-python/testtools/ChangeLog
+++ b/dev-python/testtools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testtools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.87 2014/04/27 11:45:49 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.88 2014/05/04 05:33:06 idella4 Exp $
+
+*testtools-0.9.35 (04 May 2014)
+
+ 04 May 2014; Ian Delaney <idella4@gentoo.org> +testtools-0.9.35.ebuild:
+ bump, thx for testing by Chicago
27 Apr 2014; Markus Meier <maekke@gentoo.org> testtools-0.9.34.ebuild:
arm stable, bug #506620
diff --git a/dev-python/testtools/testtools-0.9.35.ebuild b/dev-python/testtools/testtools-0.9.35.ebuild
new file mode 100644
index 000000000000..8367c537ff15
--- /dev/null
+++ b/dev-python/testtools/testtools-0.9.35.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-0.9.35.ebuild,v 1.1 2014/05/04 05:33:06 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1 versionator
+
+#SERIES="$(get_version_component_range 1-2)"
+SERIES="trunk"
+
+DESCRIPTION="Extensions to the Python unittest library"
+HOMEPAGE="https://launchpad.net/testtools http://pypi.python.org/pypi/testtools"
+SRC_URI="http://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
+
+python_test() {
+ # https://bugs.launchpad.net/testtools/+bug/1191725
+ # https://bugs.launchpad.net/testtools/+bug/1191725
+ # These tests pass run from the source, a gentooism
+ if ! python_is_python3; then
+ sed -e s':test_deferredruntest:#&:g' \
+ -e s':test_spinner:#&:g' \
+ -i ${PN}/tests/__init__.py || die
+ fi
+ # Bug 509510 re python-2.7.6
+ esetup.py test
+}