summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-12 02:59:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-12 02:59:37 +0000
commit82dfbdd7d4db600ac3ae72c3115a63a15bd04ab3 (patch)
treedcef4f27fcd87dde5d794ff2bb17c92ff6301c89 /dev-python/tinycss/tinycss-0.3.ebuild
parentInitial import, ebuild by me (diff)
downloadgentoo-2-82dfbdd7d4db600ac3ae72c3115a63a15bd04ab3.tar.gz
gentoo-2-82dfbdd7d4db600ac3ae72c3115a63a15bd04ab3.tar.bz2
gentoo-2-82dfbdd7d4db600ac3ae72c3115a63a15bd04ab3.zip
Bump
(Portage version: 2.2.3/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/tinycss/tinycss-0.3.ebuild')
-rw-r--r--dev-python/tinycss/tinycss-0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/tinycss/tinycss-0.3.ebuild b/dev-python/tinycss/tinycss-0.3.ebuild
new file mode 100644
index 000000000000..0077814c75e0
--- /dev/null
+++ b/dev-python/tinycss/tinycss-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tinycss/tinycss-0.3.ebuild,v 1.1 2013/09/12 02:59:37 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="http://github.com/SimonSapin/tinycss/ http://packages.python.org/tinycss/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES README.rst )
+
+python_test() {
+ export TINYCSS_SKIP_SPEEDUPS_TESTS=1
+ local test
+ for test in ${PN}/tests/test_*.py; do
+ py.test $test
+ done
+}