summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-26 07:46:25 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-26 07:46:25 +0000
commit0ed2d18f42fb3cf59f72157e965f22716d626a3e (patch)
treee7831c9b7fe590ea862bdd062ae3eee54af64193 /dev-python/tox/tox-1.4.3.ebuild
parentBump (diff)
downloadgentoo-2-0ed2d18f42fb3cf59f72157e965f22716d626a3e.tar.gz
gentoo-2-0ed2d18f42fb3cf59f72157e965f22716d626a3e.tar.bz2
gentoo-2-0ed2d18f42fb3cf59f72157e965f22716d626a3e.zip
bump one remove 2
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/tox/tox-1.4.3.ebuild')
-rw-r--r--dev-python/tox/tox-1.4.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/tox/tox-1.4.3.ebuild b/dev-python/tox/tox-1.4.3.ebuild
deleted file mode 100644
index c87858cc10fe..000000000000
--- a/dev-python/tox/tox-1.4.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/tox-1.4.3.ebuild,v 1.5 2014/07/06 12:50:50 mgorny Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.7-pypy-*"
-inherit distutils eutils
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="http://tox.testrun.org http://pypi.python.org/pypi/tox"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-RDEPEND="
- dev-python/setuptools
- >=dev-python/virtualenv-1.7
- dev-python/pip
- dev-python/pytest
- >=dev-python/py-1.4.9"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.4.2-rm_version_test.patch
-}
-
-src_compile() {
- distutils_src_compile
- use doc && emake -C doc html
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b build-${PYTHON_ABI} \
- install --root "${T}/test-${PYTHON_ABI}"
- PATH="${T}/test-${PYTHON_ABI}/usr/bin:${PATH}" \
- PYTHONPATH="${T}/test-${PYTHON_ABI}/$(python_get_sitedir -b)" py.test -x
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r doc/_build/html/
-}