summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-10 17:39:17 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-10 17:39:17 +0000
commit39f970d31f020ca1b4c070291e790fb3be3aa377 (patch)
tree6708da2a09f346be2bb4b3cfd19f3041a2183cdc /dev-python/tox
parentdev-python/numpy: Cleaned old (diff)
downloadgentoo-2-39f970d31f020ca1b4c070291e790fb3be3aa377.tar.gz
gentoo-2-39f970d31f020ca1b4c070291e790fb3be3aa377.tar.bz2
gentoo-2-39f970d31f020ca1b4c070291e790fb3be3aa377.zip
Upgraded test suite to ensure testing by use of the in source built content, updated PYTHON_DEPEND, resticting pypy, fixes bug #451008 by flameeyes
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/ChangeLog8
-rw-r--r--dev-python/tox/tox-1.4.2.ebuild13
2 files changed, 14 insertions, 7 deletions
diff --git a/dev-python/tox/ChangeLog b/dev-python/tox/ChangeLog
index f7d504086509..09d5e9e188b0 100644
--- a/dev-python/tox/ChangeLog
+++ b/dev-python/tox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/tox
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/ChangeLog,v 1.7 2012/10/31 11:08:28 idella4 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/ChangeLog,v 1.8 2013/01/10 17:39:17 idella4 Exp $
+
+ 11 Jan 2013; Ian Delaney <idella4@gentoo.org> tox-1.4.2.ebuild:
+ Upgraded test suite to ensure testing by use of the in source built content,
+ updated PYTHON_DEPEND, resticting pypy, fixes bug #451008 by flameeyes
31 Oct 2012; Michał Górny <mgorny@gentoo.org> tox-1.4.2.ebuild:
Use virtual for argparse.
diff --git a/dev-python/tox/tox-1.4.2.ebuild b/dev-python/tox/tox-1.4.2.ebuild
index a7646ee4fa03..c82360377b87 100644
--- a/dev-python/tox/tox-1.4.2.ebuild
+++ b/dev-python/tox/tox-1.4.2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/tox-1.4.2.ebuild,v 1.3 2012/10/31 08:56:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/tox-1.4.2.ebuild,v 1.4 2013/01/10 17:39:17 idella4 Exp $
EAPI=4
-PYTHON_DEPEND="*"
+PYTHON_DEPEND="*:2.6"
SUPPORT_PYTHON_ABIS="1"
-
+RESTRICT_PYTHON_ABIS="2.7-pypy-*"
inherit distutils eutils
DESCRIPTION="virtualenv-based automation of test activities"
@@ -38,7 +38,10 @@ src_compile() {
src_test() {
testing() {
- PYTHONPATH=. py.test -x
+ "$(PYTHON)" setup.py build -b build-${PYTHON_ABI} \
+ install --root "${T}/test-${PYTHON_ABI}"
+ PATH="${T}/test-${PYTHON_ABI}/usr/bin:${PATH}" \
+ PYTHONPATH="${T}/test-${PYTHON_ABI}/$(python_get_sitedir -b)" py.test -x
}
python_execute_function testing
}