summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-03 23:30:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-03 23:30:34 +0000
commit28af0ed79b8913b0b7bfa6c06ab330dcc43560c1 (patch)
treec82f057943e0a0f704dfaf32e9c536b8b9aabf28 /dev-python/traits
parentVersion bump for stable channel release. Remove old. (diff)
downloadgentoo-2-28af0ed79b8913b0b7bfa6c06ab330dcc43560c1.tar.gz
gentoo-2-28af0ed79b8913b0b7bfa6c06ab330dcc43560c1.tar.bz2
gentoo-2-28af0ed79b8913b0b7bfa6c06ab330dcc43560c1.zip
Version bump. Possible API break.
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/ChangeLog7
-rw-r--r--dev-python/traits/traits-4.0.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/traits/ChangeLog b/dev-python/traits/ChangeLog
index b980a7346dd2..1afd8604fa0c 100644
--- a/dev-python/traits/ChangeLog
+++ b/dev-python/traits/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/traits
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.24 2011/04/01 16:07:00 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.25 2011/08/03 23:30:34 bicatali Exp $
+
+*traits-4.0.0 (03 Aug 2011)
+
+ 03 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> +traits-4.0.0.ebuild:
+ Version bump. Possible API break.
01 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> traits-3.6.0.ebuild:
Marked ~ppc64 wrt #342297
diff --git a/dev-python/traits/traits-4.0.0.ebuild b/dev-python/traits/traits-4.0.0.ebuild
new file mode 100644
index 000000000000..31dffe3a82da
--- /dev/null
+++ b/dev-python/traits/traits-4.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.0.0.ebuild,v 1.1 2011/08/03 23:30:34 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TES="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
+SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/numpy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/numpy )"
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}