summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-04 20:31:46 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-04 20:31:46 +0000
commit67d08a879367db8cf8bf75a27fbacb9c1aa997ff (patch)
tree30073489bda2e9fad053b9a245d864b1bfbaf54f /dev-python/twisted-conch
parentDelete older ebuilds. (diff)
downloadgentoo-2-67d08a879367db8cf8bf75a27fbacb9c1aa997ff.tar.gz
gentoo-2-67d08a879367db8cf8bf75a27fbacb9c1aa997ff.tar.bz2
gentoo-2-67d08a879367db8cf8bf75a27fbacb9c1aa997ff.zip
Version bump.
(Portage version: 2.2.0_alpha29_p8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/twisted-conch')
-rw-r--r--dev-python/twisted-conch/ChangeLog8
-rw-r--r--dev-python/twisted-conch/twisted-conch-11.0.0.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/twisted-conch/ChangeLog b/dev-python/twisted-conch/ChangeLog
index fb999edf6d12..b967b392780e 100644
--- a/dev-python/twisted-conch/ChangeLog
+++ b/dev-python/twisted-conch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-conch
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.68 2011/01/25 17:03:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.69 2011/04/04 20:31:46 arfrever Exp $
+
+*twisted-conch-11.0.0 (04 Apr 2011)
+
+ 04 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +twisted-conch-11.0.0.ebuild:
+ Version bump.
25 Jan 2011; Jeroen Roovers <jer@gentoo.org> twisted-conch-10.2.0.ebuild:
Stable for HPPA (bug #350894).
diff --git a/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild b/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild
new file mode 100644
index 000000000000..a905a2956b0b
--- /dev/null
+++ b/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-11.0.0.ebuild,v 1.1 2011/04/04 20:31:46 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Conch"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted SSHv2 implementation"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
+ dev-python/pyasn1
+ dev-python/pycrypto"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/conch twisted/plugins"
+
+src_prepare() {
+ distutils_src_prepare
+
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_checkKeyAsRoot/_&/" -i twisted/conch/test/test_checkers.py
+ sed -e "s/test_getPrivateKeysAsRoot/_&/" -i twisted/conch/test/test_openssh_compat.py
+ fi
+}