summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-21 04:50:48 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-21 04:50:48 +0000
commitb3bc04838a39d36ab4754ee67cf0d43bd3d52fce (patch)
treeadb3ee2b33b0c52a35034a1366d0b3caf52cf79d /dev-python/twisted-core
parentRemove old (diff)
downloadgentoo-2-b3bc04838a39d36ab4754ee67cf0d43bd3d52fce.tar.gz
gentoo-2-b3bc04838a39d36ab4754ee67cf0d43bd3d52fce.tar.bz2
gentoo-2-b3bc04838a39d36ab4754ee67cf0d43bd3d52fce.zip
Remove old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/twisted-core')
-rw-r--r--dev-python/twisted-core/ChangeLog7
-rw-r--r--dev-python/twisted-core/twisted-core-10.2.0.ebuild107
-rw-r--r--dev-python/twisted-core/twisted-core-11.0.0.ebuild107
-rw-r--r--dev-python/twisted-core/twisted-core-11.1.0.ebuild103
-rw-r--r--dev-python/twisted-core/twisted-core-12.0.0.ebuild106
-rw-r--r--dev-python/twisted-core/twisted-core-12.2.0.ebuild117
6 files changed, 6 insertions, 541 deletions
diff --git a/dev-python/twisted-core/ChangeLog b/dev-python/twisted-core/ChangeLog
index 36e7192b45d9..03f95a4aee62 100644
--- a/dev-python/twisted-core/ChangeLog
+++ b/dev-python/twisted-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/ChangeLog,v 1.17 2014/01/19 08:09:58 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/ChangeLog,v 1.18 2014/01/21 04:50:48 patrick Exp $
+
+ 21 Jan 2014; Patrick Lauer <patrick@gentoo.org> -twisted-core-10.2.0.ebuild,
+ -twisted-core-11.0.0.ebuild, -twisted-core-11.1.0.ebuild,
+ -twisted-core-12.0.0.ebuild, -twisted-core-12.2.0.ebuild:
+ Remove old
*twisted-core-13.2.0 (19 Jan 2014)
diff --git a/dev-python/twisted-core/twisted-core-10.2.0.ebuild b/dev-python/twisted-core/twisted-core-10.2.0.ebuild
deleted file mode 100644
index 543a14892132..000000000000
--- a/dev-python/twisted-core/twisted-core-10.2.0.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/twisted-core-10.2.0.ebuild,v 1.1 2013/08/03 09:34:50 mgorny Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-MY_PACKAGE="Core"
-
-inherit eutils twisted versionator
-
-DESCRIPTION="An asynchronous networking framework written in Python"
-HOMEPAGE="http://www.twistedmatrix.com/ http://pypi.python.org/pypi/Twisted"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="crypt gtk serial"
-
-DEPEND=">=net-zope/zope-interface-3.0.1
- crypt? ( >=dev-python/pyopenssl-0.5.1 )
- gtk? ( >=dev-python/pygtk-1.99 )
- serial? ( dev-python/pyserial )"
-RDEPEND="${DEPEND}
- !dev-python/twisted"
-
-DOCS="CREDITS NEWS README"
-
-src_prepare(){
- distutils_src_prepare
-
- # Give a load-sensitive test a better chance of succeeding.
- epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
-
- # Pass valid arguments to "head" in the zsh completion function.
- epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
-
- # Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.
- epatch "${FILESDIR}/${PN}-9.0.0-respect_TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE.patch"
-
- if [[ "${EUID}" -eq 0 ]]; then
- # Disable tests failing with root permissions.
- sed \
- -e "s/test_newPluginsOnReadOnlyPath/_&/" \
- -e "s/test_deployedMode/_&/" \
- -i twisted/test/test_plugin.py
- fi
-}
-
-src_test() {
- testing() {
- local return_status="0"
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests" --no-compile || die "Installation of tests failed with $(python_get_implementation) $(python_get_version)"
-
- pushd "${T}/tests${EPREFIX}$(python_get_sitedir)" > /dev/null || die
-
- # Skip broken tests.
- sed -e "s/test_buildAllTarballs/_&/" -i twisted/python/test/test_release.py || die "sed failed"
-
- # Prevent it from pulling in plugins from already installed twisted packages.
- rm -f twisted/plugins/__init__.py
-
- # An empty file doesn't work because the tests check for doc strings in all packages.
- echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
-
- if ! PYTHONPATH="." "${T}/tests${EPREFIX}/usr/bin/trial" twisted; then
- if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
- die "Tests failed with $(python_get_implementation) $(python_get_version)"
- else
- return_status="1"
- fi
- fi
-
- popd > /dev/null || die
- rm -fr "${T}/tests"
- return "${return_status}"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/trial"
-
- postinstallational_preparation() {
- touch "${ED}$(python_get_sitedir)/Twisted-${PV}-py$(python_get_version).egg-info"
-
- # Delete dropin.cache to avoid collisions.
- # dropin.cache is regenerated in pkg_postinst().
- rm -f "${ED}$(python_get_sitedir)/twisted/plugins/dropin.cache"
- }
- python_execute_function -q postinstallational_preparation
-
- # Don't install index.xhtml page.
- doman doc/man/*.?
- insinto /usr/share/doc/${PF}
- doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
-
- newconfd "${FILESDIR}/twistd.conf" twistd
- newinitd "${FILESDIR}/twistd.init" twistd
-
- # zsh completion
- insinto /usr/share/zsh/site-functions
- doins twisted/python/_twisted_zsh_stub
-}
diff --git a/dev-python/twisted-core/twisted-core-11.0.0.ebuild b/dev-python/twisted-core/twisted-core-11.0.0.ebuild
deleted file mode 100644
index e55cdece7e66..000000000000
--- a/dev-python/twisted-core/twisted-core-11.0.0.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/twisted-core-11.0.0.ebuild,v 1.1 2013/08/03 09:34:50 mgorny Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-MY_PACKAGE="Core"
-
-inherit eutils twisted versionator
-
-DESCRIPTION="An asynchronous networking framework written in Python"
-HOMEPAGE="http://www.twistedmatrix.com/ http://pypi.python.org/pypi/Twisted"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="crypt gtk serial"
-
-DEPEND=">=net-zope/zope-interface-3.0.1
- crypt? ( >=dev-python/pyopenssl-0.5.1 )
- gtk? ( >=dev-python/pygtk-1.99 )
- serial? ( dev-python/pyserial )"
-RDEPEND="${DEPEND}
- !dev-python/twisted"
-
-DOCS="CREDITS NEWS README"
-
-src_prepare(){
- distutils_src_prepare
-
- # Give a load-sensitive test a better chance of succeeding.
- epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
-
- # Pass valid arguments to "head" in the zsh completion function.
- epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
-
- # Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.
- epatch "${FILESDIR}/${PN}-9.0.0-respect_TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE.patch"
-
- if [[ "${EUID}" -eq 0 ]]; then
- # Disable tests failing with root permissions.
- sed \
- -e "s/test_newPluginsOnReadOnlyPath/_&/" \
- -e "s/test_deployedMode/_&/" \
- -i twisted/test/test_plugin.py
- fi
-}
-
-src_test() {
- testing() {
- local return_status="0"
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests" --no-compile || die "Installation of tests failed with $(python_get_implementation) $(python_get_version)"
-
- pushd "${T}/tests${EPREFIX}$(python_get_sitedir)" > /dev/null || die
-
- # Skip broken tests.
- sed -e "s/test_buildAllTarballs/_&/" -i twisted/python/test/test_release.py || die "sed failed"
-
- # Prevent it from pulling in plugins from already installed twisted packages.
- rm -f twisted/plugins/__init__.py
-
- # An empty file doesn't work because the tests check for doc strings in all packages.
- echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
-
- if ! PYTHONPATH="." "${T}/tests${EPREFIX}/usr/bin/trial" twisted; then
- if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
- die "Tests failed with $(python_get_implementation) $(python_get_version)"
- else
- return_status="1"
- fi
- fi
-
- popd > /dev/null || die
- rm -fr "${T}/tests"
- return "${return_status}"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/trial"
-
- postinstallational_preparation() {
- touch "${ED}$(python_get_sitedir)/Twisted-${PV}-py$(python_get_version).egg-info"
-
- # Delete dropin.cache to avoid collisions.
- # dropin.cache is regenerated in pkg_postinst().
- rm -f "${ED}$(python_get_sitedir)/twisted/plugins/dropin.cache"
- }
- python_execute_function -q postinstallational_preparation
-
- # Don't install index.xhtml page.
- doman doc/man/*.?
- insinto /usr/share/doc/${PF}
- doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
-
- newconfd "${FILESDIR}/twistd.conf" twistd
- newinitd "${FILESDIR}/twistd.init" twistd
-
- # zsh completion
- insinto /usr/share/zsh/site-functions
- doins twisted/python/_twisted_zsh_stub
-}
diff --git a/dev-python/twisted-core/twisted-core-11.1.0.ebuild b/dev-python/twisted-core/twisted-core-11.1.0.ebuild
deleted file mode 100644
index e1471e8151cd..000000000000
--- a/dev-python/twisted-core/twisted-core-11.1.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/twisted-core-11.1.0.ebuild,v 1.1 2013/08/03 09:34:50 mgorny Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-MY_PACKAGE="Core"
-
-inherit eutils twisted versionator
-
-DESCRIPTION="An asynchronous networking framework written in Python"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="crypt gtk serial"
-
-DEPEND="net-zope/zope-interface
- crypt? ( >=dev-python/pyopenssl-0.10 )
- gtk? ( dev-python/pygtk:2 )
- serial? ( dev-python/pyserial )"
-RDEPEND="${DEPEND}
- !dev-python/twisted"
-
-DOCS="CREDITS NEWS README"
-
-src_prepare(){
- distutils_src_prepare
-
- # Give a load-sensitive test a better chance of succeeding.
- epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
-
- # Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.
- epatch "${FILESDIR}/${PN}-9.0.0-respect_TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE.patch"
-
- if [[ "${EUID}" -eq 0 ]]; then
- # Disable tests failing with root permissions.
- sed \
- -e "s/test_newPluginsOnReadOnlyPath/_&/" \
- -e "s/test_deployedMode/_&/" \
- -i twisted/test/test_plugin.py
- fi
-}
-
-src_test() {
- testing() {
- local exit_status="0"
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests" --no-compile || die "Installation of tests failed with $(python_get_implementation_and_version)"
-
- pushd "${T}/tests${EPREFIX}$(python_get_sitedir)" > /dev/null || die
-
- # Skip broken tests.
- sed -e "s/test_buildAllTarballs/_&/" -i twisted/python/test/test_release.py || die "sed failed"
-
- # http://twistedmatrix.com/trac/ticket/5375
- sed -e "/class ZshIntegrationTestCase/,/^$/d" -i twisted/scripts/test/test_scripts.py || die "sed failed"
-
- # Prevent it from pulling in plugins from already installed twisted packages.
- rm -f twisted/plugins/__init__.py
-
- # An empty file doesn't work because the tests check for doc strings in all packages.
- echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
-
- if ! PYTHONPATH="." "${T}/tests${EPREFIX}/usr/bin/trial" twisted; then
- if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
- die "Tests failed with $(python_get_implementation_and_version)"
- else
- exit_status="1"
- fi
- fi
-
- popd > /dev/null || die
- rm -fr "${T}/tests"
- return "${exit_status}"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_clean_installation_image
-
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/trial"
-
- postinstallational_preparation() {
- touch "${ED}$(python_get_sitedir)/Twisted-${PV}-py$(python_get_version).egg-info"
-
- # Delete dropin.cache to avoid collisions.
- # dropin.cache is regenerated in pkg_postinst().
- rm -f "${ED}$(python_get_sitedir)/twisted/plugins/dropin.cache"
- }
- python_execute_function -q postinstallational_preparation
-
- # Don't install index.xhtml page.
- doman doc/man/*.?
- insinto /usr/share/doc/${PF}
- doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
-
- newconfd "${FILESDIR}/twistd.conf" twistd
- newinitd "${FILESDIR}/twistd.init" twistd
-}
diff --git a/dev-python/twisted-core/twisted-core-12.0.0.ebuild b/dev-python/twisted-core/twisted-core-12.0.0.ebuild
deleted file mode 100644
index 38ffe92967b7..000000000000
--- a/dev-python/twisted-core/twisted-core-12.0.0.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/twisted-core-12.0.0.ebuild,v 1.1 2013/08/03 09:34:50 mgorny Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-MY_PACKAGE="Core"
-
-inherit eutils twisted versionator
-
-DESCRIPTION="An asynchronous networking framework written in Python"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="crypt gtk serial"
-
-DEPEND="net-zope/zope-interface
- crypt? ( >=dev-python/pyopenssl-0.10 )
- gtk? ( dev-python/pygtk:2 )
- serial? ( dev-python/pyserial )"
-RDEPEND="${DEPEND}
- !dev-python/twisted"
-
-DOCS="CREDITS NEWS README"
-
-src_prepare(){
- distutils_src_prepare
-
- # Give a load-sensitive test a better chance of succeeding.
- epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
-
- # Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.
- epatch "${FILESDIR}/${PN}-9.0.0-respect_TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE.patch"
-
- # Fix a test that fails in some timezones.
- epatch "${FILESDIR}/${P}-fix-test-timeFormatting.patch"
-
- if [[ "${EUID}" -eq 0 ]]; then
- # Disable tests failing with root permissions.
- sed \
- -e "s/test_newPluginsOnReadOnlyPath/_&/" \
- -e "s/test_deployedMode/_&/" \
- -i twisted/test/test_plugin.py
- fi
-}
-
-src_test() {
- testing() {
- local exit_status="0"
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests" --no-compile || die "Installation of tests failed with $(python_get_implementation_and_version)"
-
- pushd "${T}/tests${EPREFIX}$(python_get_sitedir)" > /dev/null || die
-
- # Skip broken tests.
- sed -e "s/test_buildAllTarballs/_&/" -i twisted/python/test/test_release.py || die "sed failed"
-
- # http://twistedmatrix.com/trac/ticket/5375
- sed -e "/class ZshIntegrationTestCase/,/^$/d" -i twisted/scripts/test/test_scripts.py || die "sed failed"
-
- # Prevent it from pulling in plugins from already installed twisted packages.
- rm -f twisted/plugins/__init__.py
-
- # An empty file doesn't work because the tests check for doc strings in all packages.
- echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
-
- if ! PYTHONPATH="." "${T}/tests${EPREFIX}/usr/bin/trial" twisted; then
- if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
- die "Tests failed with $(python_get_implementation_and_version)"
- else
- exit_status="1"
- fi
- fi
-
- popd > /dev/null || die
- rm -fr "${T}/tests"
- return "${exit_status}"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_clean_installation_image
-
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/trial"
-
- postinstallational_preparation() {
- touch "${ED}$(python_get_sitedir)/Twisted-${PV}-py$(python_get_version).egg-info"
-
- # Delete dropin.cache to avoid collisions.
- # dropin.cache is regenerated in pkg_postinst().
- rm -f "${ED}$(python_get_sitedir)/twisted/plugins/dropin.cache"
- }
- python_execute_function -q postinstallational_preparation
-
- # Don't install index.xhtml page.
- doman doc/man/*.?
- insinto /usr/share/doc/${PF}
- doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
-
- newconfd "${FILESDIR}/twistd.conf" twistd
- newinitd "${FILESDIR}/twistd.init" twistd
-}
diff --git a/dev-python/twisted-core/twisted-core-12.2.0.ebuild b/dev-python/twisted-core/twisted-core-12.2.0.ebuild
deleted file mode 100644
index e987bd9c44ed..000000000000
--- a/dev-python/twisted-core/twisted-core-12.2.0.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/twisted-core-12.2.0.ebuild,v 1.2 2013/08/06 17:05:08 mgorny Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.* *-jython"
-# A couple of failures (refcounting, version-checking), but sufficiently
-# functional to be useful, so restrict just the tests.
-PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
-MY_PACKAGE="Core"
-
-inherit eutils twisted versionator
-
-DESCRIPTION="An asynchronous networking framework written in Python"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="crypt gtk serial"
-
-DEPEND="net-zope/zope-interface
- crypt? ( >=dev-python/pyopenssl-0.10 )
- gtk? ( dev-python/pygtk:2 )
- serial? ( dev-python/pyserial )"
-RDEPEND="${DEPEND}
- !dev-python/twisted"
-
-# Needed to make the sendmsg extension work
-# (see http://twistedmatrix.com/trac/ticket/5701 )
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="CREDITS NEWS README"
-
-src_prepare(){
- distutils_src_prepare
-
- # Give a load-sensitive test a better chance of succeeding.
- epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
-
- # Skip a test if twisted conch is not available
- # (see Twisted ticket #5703)
- epatch "${FILESDIR}/twisted-core-12.1.0-remove-tests-conch-dependency.patch"
-
- # Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.
- epatch "${FILESDIR}/${PN}-9.0.0-respect_TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE.patch"
-
- if [[ "${EUID}" -eq 0 ]]; then
- # Disable tests failing with root permissions.
- sed \
- -e "s/test_newPluginsOnReadOnlyPath/_&/" \
- -e "s/test_deployedMode/_&/" \
- -i twisted/test/test_plugin.py
- fi
-}
-
-src_test() {
- testing() {
- local exit_status="0"
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests-${PYTHON_ABI}" --no-compile || die "Installation of tests failed with $(python_get_implementation_and_version)"
-
- pushd "${T}/tests-${PYTHON_ABI}${EPREFIX}$(python_get_sitedir)" > /dev/null || die
-
- # Skip broken tests.
- sed -e "s/test_buildAllTarballs/_&/" -i twisted/python/test/test_release.py || die "sed failed"
-
- # http://twistedmatrix.com/trac/ticket/5375
- sed -e "/class ZshIntegrationTestCase/,/^$/d" -i twisted/scripts/test/test_scripts.py || die "sed failed"
-
- # tap2rpm is already skipped if rpm is not installed, but fails for me on a Gentoo box with it present.
- # I currently lack the cycles to track this failure down.
- rm twisted/scripts/test/test_tap2rpm.py
-
- # Prevent it from pulling in plugins from already installed twisted packages.
- rm -f twisted/plugins/__init__.py
-
- # An empty file doesn't work because the tests check for doc strings in all packages.
- echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
-
- if ! PYTHONPATH="." "${T}/tests-${PYTHON_ABI}${EPREFIX}/usr/bin/trial" twisted; then
- if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
- die "Tests failed with $(python_get_implementation_and_version)"
- else
- exit_status="1"
- fi
- fi
-
- popd > /dev/null || die
- return "${exit_status}"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_clean_installation_image
-
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/trial"
-
- postinstallational_preparation() {
- touch "${ED}$(python_get_sitedir)/Twisted-${PV}-py$(python_get_version).egg-info"
-
- # Delete dropin.cache to avoid collisions.
- # dropin.cache is regenerated in pkg_postinst().
- rm -f "${ED}$(python_get_sitedir)/twisted/plugins/dropin.cache"
- }
- python_execute_function -q postinstallational_preparation
-
- # Don't install index.xhtml page.
- doman doc/man/*.?
- insinto /usr/share/doc/${PF}
- doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
-
- newconfd "${FILESDIR}/twistd.conf" twistd
- newinitd "${FILESDIR}/twistd.init" twistd
-}