summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-12 03:02:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-12 03:02:26 +0000
commit799f183ee1732553a0f899938fc2fb5ec54dfef2 (patch)
treef52219918e5d0741f0cb3b67b097706ddc652916 /dev-python/weasyprint
parentBump (diff)
downloadgentoo-2-799f183ee1732553a0f899938fc2fb5ec54dfef2.tar.gz
gentoo-2-799f183ee1732553a0f899938fc2fb5ec54dfef2.tar.bz2
gentoo-2-799f183ee1732553a0f899938fc2fb5ec54dfef2.zip
Initial import, ebuild by me
(Portage version: 2.2.3/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/ChangeLog9
-rw-r--r--dev-python/weasyprint/Manifest3
-rw-r--r--dev-python/weasyprint/metadata.xml8
-rw-r--r--dev-python/weasyprint/weasyprint-0.19.2.ebuild34
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/weasyprint/ChangeLog b/dev-python/weasyprint/ChangeLog
new file mode 100644
index 000000000000..9c7a54d45f5d
--- /dev/null
+++ b/dev-python/weasyprint/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/weasyprint
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.1 2013/09/12 03:02:26 patrick Exp $
+
+*weasyprint-0.19.2 (12 Sep 2013)
+
+ 12 Sep 2013; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +weasyprint-0.19.2.ebuild:
+ Initial import, ebuild by me
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
new file mode 100644
index 000000000000..70a94f79f59a
--- /dev/null
+++ b/dev-python/weasyprint/Manifest
@@ -0,0 +1,3 @@
+DIST WeasyPrint-0.19.2.tar.gz 324312 SHA256 63fa62b40a5bd3a1f14887950f6f40d73fff752507cd41f0040606b3d5399ba4 SHA512 c491ec6788b164857265f11391148d761a737a47045288258f5584b277d58075e49384a9c0fa93ab849adbc1672684518039e2cc7bcf76b684dbab196f666166 WHIRLPOOL 3490b2724a0212a182eb2e9888f8fbec3b5173b0fcd5917ca51c963ea128c7071b59dd30f5b006628ccb3f8aa2f4e3dcc45eea8698182b77f597aacdfdf87198
+EBUILD weasyprint-0.19.2.ebuild 959 SHA256 c6c0b952454308c5b61194a815ddba33b8c3fd9931947d61d75d61034dfc076e SHA512 86ef5a13a66a95e3f3e8ecf97cd30358a7d32da1740e54c7fc6af5cb6b093a6e566e4516bb51289ae927efb6bcf71459daf6839c97c29305dc150383c27fd1e8 WHIRLPOOL d4a1ff1a642c4a72ebb9c9e6ede502d8f26ff3425f0bc3682f8670d8c35a1d7b6644c475d43ca1ec5ece183a8dd89413d35d45abba7198378df651f740d73a2a
+MISC metadata.xml 233 SHA256 e12a8d932622a4d26fc2bed0756100922a610aed8d56c8f3e809961fdd9391dd SHA512 e5a9aea32f57fb9fe2f52fac0566f39a8406ca65c958059cbeeec8edc9f2d00f652893c9bf985279ab0e82027c1ce8efdd10a39875ba980a8cc52c588afbbd16 WHIRLPOOL 35df23ca9ff4885b227fc0556e4ecc29897a34807a99e1824517af97f9cfac6b3d9ce525544a24784a558985c43bbd770dc1f1070ef0d72a56abc5cf7c4fb712
diff --git a/dev-python/weasyprint/metadata.xml b/dev-python/weasyprint/metadata.xml
new file mode 100644
index 000000000000..278a92a86bbe
--- /dev/null
+++ b/dev-python/weasyprint/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">WeasyPrint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/weasyprint/weasyprint-0.19.2.ebuild b/dev-python/weasyprint/weasyprint-0.19.2.ebuild
new file mode 100644
index 000000000000..69d9a5294816
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.19.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/weasyprint-0.19.2.ebuild,v 1.1 2013/09/12 03:02:26 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF."
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://http://weasyprint.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="x11-libs/cairo
+ x11-libs/pango
+ media-gfx/cairosvg
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/pyphen[${PYTHON_USEDEP}]
+ "
+ # x11-libs/gdk-pixbuf # optional dep
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"