summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-24 07:04:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-24 07:04:49 +0000
commit2cc2fd1c98491cf98953c4e865045805b412c331 (patch)
tree988224bb8dec5c32565be11b85b806d38c7fdbac /dev-python/webob
parentany mod support will do (diff)
downloadgentoo-2-2cc2fd1c98491cf98953c4e865045805b412c331.tar.gz
gentoo-2-2cc2fd1c98491cf98953c4e865045805b412c331.tar.bz2
gentoo-2-2cc2fd1c98491cf98953c4e865045805b412c331.zip
Bump
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/ChangeLog8
-rw-r--r--dev-python/webob/webob-1.2.2.ebuild51
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index 051813ef2fd0..b72b8fc8119e 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.54 2012/08/05 06:13:32 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.55 2012/08/24 07:04:49 patrick Exp $
+
+*webob-1.2.2 (24 Aug 2012)
+
+ 24 Aug 2012; Patrick Lauer <patrick@gentoo.org> +webob-1.2.2.ebuild:
+ Bump
05 Aug 2012; Anthony G. Basile <blueness@gentoo.org> webob-1.1.ebuild:
Stable arm, bug #427546
@@ -206,4 +211,3 @@
02 Jul 2008; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+webob-0.9.2.ebuild:
Initial commit.
-
diff --git a/dev-python/webob/webob-1.2.2.ebuild b/dev-python/webob/webob-1.2.2.ebuild
new file mode 100644
index 000000000000..1d91c62a1d9f
--- /dev/null
+++ b/dev-python/webob/webob-1.2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.2.2.ebuild,v 1.1 2012/08/24 07:04:49 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="WebOb"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://pythonpaste.org/webob/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/webtest )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}