summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-16 13:17:01 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-16 13:17:01 +0000
commitdc53c45bde45539f17d8231d48ac46d2ea76c297 (patch)
tree1d5996683e2077bf9ccb3683ad4fe68796175d43 /dev-python/webob
parentrm old (diff)
downloadgentoo-2-dc53c45bde45539f17d8231d48ac46d2ea76c297.tar.gz
gentoo-2-dc53c45bde45539f17d8231d48ac46d2ea76c297.tar.bz2
gentoo-2-dc53c45bde45539f17d8231d48ac46d2ea76c297.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/ChangeLog6
-rw-r--r--dev-python/webob/webob-1.2.3-r1.ebuild45
-rw-r--r--dev-python/webob/webob-1.2.3.ebuild45
-rw-r--r--dev-python/webob/webob-1.3.1.ebuild43
4 files changed, 5 insertions, 134 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index a2fd6e8c4fdb..46914745bcaf 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.98 2015/01/02 12:26:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.99 2015/01/16 13:17:01 idella4 Exp $
+
+ 16 Jan 2015; Ian Delaney <idella4@gentoo.org> -webob-1.2.3-r1.ebuild,
+ -webob-1.2.3.ebuild, -webob-1.3.1.ebuild:
+ rm old
02 Jan 2015; Agostino Sarubbo <ago@gentoo.org> webob-1.4.ebuild:
Stable for sparc, wrt bug #530620
diff --git a/dev-python/webob/webob-1.2.3-r1.ebuild b/dev-python/webob/webob-1.2.3-r1.ebuild
deleted file mode 100644
index 0365dee149e5..000000000000
--- a/dev-python/webob/webob-1.2.3-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.2.3-r1.ebuild,v 1.15 2014/12/20 06:30:26 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-
-inherit distutils-r1
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${P}-tests.patch )
-
-python_compile_all() {
- if use doc; then
- "${PYTHON}" setup.py build_sphinx || die
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( build/sphinx/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/webob/webob-1.2.3.ebuild b/dev-python/webob/webob-1.2.3.ebuild
deleted file mode 100644
index 2db436527a3e..000000000000
--- a/dev-python/webob/webob-1.2.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.2.3.ebuild,v 1.11 2013/04/02 13:19:36 ago Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.1"
-DISTUTILS_SRC_TEST=nosetests
-
-inherit distutils
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- "$(PYTHON -f)" setup.py build_sphinx || die
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r build/sphinx/html/
- fi
-}
diff --git a/dev-python/webob/webob-1.3.1.ebuild b/dev-python/webob/webob-1.3.1.ebuild
deleted file mode 100644
index 0fbc6e3584ca..000000000000
--- a/dev-python/webob/webob-1.3.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.3.1.ebuild,v 1.4 2014/12/20 06:30:26 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-python_compile_all() {
- if use doc; then
- "${PYTHON}" setup.py build_sphinx || die "Doc build failed"
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-}