summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-04 07:48:43 +0000
committerJustin Lecher <jlec@gentoo.org>2013-06-04 07:48:43 +0000
commitcbfda59e3178b1dc943a9d8a73ca681b0b912df1 (patch)
tree48c51a85bbeccbe1445a1ac72403aefaf0d76f82 /dev-python/whirlpool
parentbump (diff)
downloadgentoo-2-cbfda59e3178b1dc943a9d8a73ca681b0b912df1.tar.gz
gentoo-2-cbfda59e3178b1dc943a9d8a73ca681b0b912df1.tar.bz2
gentoo-2-cbfda59e3178b1dc943a9d8a73ca681b0b912df1.zip
dev-python/whirlpool: Install data files into /usr/share/PN
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-python/whirlpool')
-rw-r--r--dev-python/whirlpool/ChangeLog8
-rw-r--r--dev-python/whirlpool/whirlpool-0.3-r1.ebuild (renamed from dev-python/whirlpool/whirlpool-0.3.ebuild)9
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-python/whirlpool/ChangeLog b/dev-python/whirlpool/ChangeLog
index f8c5e56afec6..db4c37eb1d3c 100644
--- a/dev-python/whirlpool/ChangeLog
+++ b/dev-python/whirlpool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/whirlpool
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/whirlpool/ChangeLog,v 1.1 2013/06/03 19:49:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/whirlpool/ChangeLog,v 1.2 2013/06/04 07:48:43 jlec Exp $
+
+*whirlpool-0.3-r1 (04 Jun 2013)
+
+ 04 Jun 2013; Justin Lecher <jlec@gentoo.org> -whirlpool-0.3.ebuild,
+ +whirlpool-0.3-r1.ebuild:
+ Install data files into /usr/share/PN
*whirlpool-0.3 (03 Jun 2013)
diff --git a/dev-python/whirlpool/whirlpool-0.3.ebuild b/dev-python/whirlpool/whirlpool-0.3-r1.ebuild
index 56963b4a8d3a..69e442abe1a0 100644
--- a/dev-python/whirlpool/whirlpool-0.3.ebuild
+++ b/dev-python/whirlpool/whirlpool-0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/whirlpool/whirlpool-0.3.ebuild,v 1.1 2013/06/03 19:49:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/whirlpool/whirlpool-0.3-r1.ebuild,v 1.1 2013/06/04 07:48:43 jlec Exp $
EAPI=5
@@ -26,6 +26,13 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MY_P}
+python_prepare_all() {
+ sed \
+ -e "/data_files/s:whirlpool:share/whirlpool:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
${PYTHON} "${FILESDIR}"/tests.py || die
}