summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-17 02:11:37 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-17 02:11:37 +0000
commit9b082f45e30bbc3848b8ffb04e33703ac5980081 (patch)
treef6bf1a0b867874506b2f723734d40847b73dde07 /dev-python/ws4py
parentAdd arm love. (diff)
downloadgentoo-2-9b082f45e30bbc3848b8ffb04e33703ac5980081.tar.gz
gentoo-2-9b082f45e30bbc3848b8ffb04e33703ac5980081.tar.bz2
gentoo-2-9b082f45e30bbc3848b8ffb04e33703ac5980081.zip
Version bump #424135 by Ian Delaney.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/ChangeLog8
-rw-r--r--dev-python/ws4py/ws4py-0.2.2.ebuild46
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild18
3 files changed, 62 insertions, 10 deletions
diff --git a/dev-python/ws4py/ChangeLog b/dev-python/ws4py/ChangeLog
index 9f8696bc9aca..e095a5ae1b9b 100644
--- a/dev-python/ws4py/ChangeLog
+++ b/dev-python/ws4py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ws4py
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.4 2012/06/11 14:13:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.5 2012/07/17 02:11:37 vapier Exp $
+
+*ws4py-0.2.2 (17 Jul 2012)
+
+ 17 Jul 2012; Mike Frysinger <vapier@gentoo.org> +ws4py-0.2.2.ebuild,
+ ws4py-9999.ebuild:
+ Version bump #424135 by Ian Delaney.
11 Jun 2012; Michał Górny <mgorny@gentoo.org> ws4py-0.2.1-r1.ebuild,
ws4py-0.2.1-r2.ebuild, ws4py-0.2.1.ebuild, ws4py-9999.ebuild:
diff --git a/dev-python/ws4py/ws4py-0.2.2.ebuild b/dev-python/ws4py/ws4py-0.2.2.ebuild
new file mode 100644
index 000000000000..44f3d6d1c98b
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-0.2.2.ebuild,v 1.1 2012/07/17 02:11:37 vapier Exp $
+
+# The gevent package isn't in the tree yet, so we delete
+# those implementations.
+#
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ...
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket support for Python"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server test +threads"
+
+RDEPEND="client? ( dev-lang/python[threads?] )"
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/cherrypy
+ dev-python/gevent
+ )"
+
+src_install() {
+ distutils_src_install
+ # We don't have a gevent pkg in the tree, so punt.
+ rm -rf "${ED}$(python_get_sitedir)"/ws4py/*/gevent*.py
+ use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
+}
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
index 28b8f9f78fc2..3645fc6837d0 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-9999.ebuild,v 1.3 2012/06/11 14:13:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-9999.ebuild,v 1.4 2012/07/17 02:11:37 vapier Exp $
# The gevent package isn't in the tree yet, so we delete
# those implementations.
@@ -10,7 +10,8 @@
# Same for www-servers/tornado and USE=client ...
EAPI="4"
-PYTHON_DEPEND="2"
+PYTHON_DEPEND="2:2.6"
+DISTUTILS_SRC_TEST="setup.py"
inherit distutils eutils
if [[ ${PV} == "9999" ]] ; then
@@ -27,15 +28,14 @@ HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
LICENSE="BSD"
SLOT="0"
-IUSE="+client +server +threads"
+IUSE="+client +server test +threads"
RDEPEND="client? ( dev-lang/python[threads?] )"
-DEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-process-data.patch
- distutils_src_prepare
-}
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/cherrypy
+ dev-python/gevent
+ )"
src_install() {
distutils_src_install