summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-03 12:41:58 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-03 12:41:58 +0000
commit9654fd95c68b0b672b31a701ea35474170eb9547 (patch)
treeb19be1a66051cf4355766cc1ead702bb172dc9e9 /dev-python/wsgiintercept
parentFix from upstream for backtrace tests #497566 by eroen. (diff)
downloadgentoo-2-9654fd95c68b0b672b31a701ea35474170eb9547.tar.gz
gentoo-2-9654fd95c68b0b672b31a701ea35474170eb9547.tar.bz2
gentoo-2-9654fd95c68b0b672b31a701ea35474170eb9547.zip
Version Bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/wsgiintercept')
-rw-r--r--dev-python/wsgiintercept/ChangeLog9
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/wsgiintercept/ChangeLog b/dev-python/wsgiintercept/ChangeLog
index 68d35e2f6aa3..4ddee2ee5706 100644
--- a/dev-python/wsgiintercept/ChangeLog
+++ b/dev-python/wsgiintercept/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wsgiintercept
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.3 2013/11/27 17:55:42 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.4 2014/02/03 12:41:58 jlec Exp $
+
+*wsgiintercept-0.6.1 (03 Feb 2014)
+
+ 03 Feb 2014; Justin Lecher <jlec@gentoo.org> +wsgiintercept-0.6.1.ebuild:
+ Version Bump
27 Nov 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add upstream information
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild
new file mode 100644
index 000000000000..e5a200d9f5a1
--- /dev/null
+++ b/dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild,v 1.1 2014/02/03 12:41:58 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+MY_PN="wsgi_intercept"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI application in place of a real URI for testing"
+HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://github.com/cdent/python3-wsgi-intercept"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/0.6.0-fix-tests.patch" )
+
+python_test() {
+ py.test || die
+}