summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-07-01 06:35:58 +0000
committerJustin Lecher <jlec@gentoo.org>2014-07-01 06:35:58 +0000
commitb21108873f35373cb71de43fd74d133cac469700 (patch)
treee5fdc76d6670b9d1d3f66df4028e9b90409f6dea /dev-python/wsgiintercept
parentdev-python/pytools: Version Bump (diff)
downloadgentoo-2-b21108873f35373cb71de43fd74d133cac469700.tar.gz
gentoo-2-b21108873f35373cb71de43fd74d133cac469700.tar.bz2
gentoo-2-b21108873f35373cb71de43fd74d133cac469700.zip
dev-python/wsgiintercept: Version Bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/wsgiintercept')
-rw-r--r--dev-python/wsgiintercept/ChangeLog7
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.6.5.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/wsgiintercept/ChangeLog b/dev-python/wsgiintercept/ChangeLog
index 68573c308eec..562e6d98f805 100644
--- a/dev-python/wsgiintercept/ChangeLog
+++ b/dev-python/wsgiintercept/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wsgiintercept
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.9 2014/06/10 10:30:20 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.10 2014/07/01 06:35:58 jlec Exp $
+
+*wsgiintercept-0.6.5 (01 Jul 2014)
+
+ 01 Jul 2014; Justin Lecher <jlec@gentoo.org> +wsgiintercept-0.6.5.ebuild:
+ Version Bump
10 Jun 2014; Ian Delaney <idella4@gentoo.org> -wsgiintercept-0.5.1.ebuild,
-wsgiintercept-0.6.0.ebuild, -wsgiintercept-0.6.1.ebuild,
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.6.5.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.6.5.ebuild
new file mode 100644
index 000000000000..576706ed4b1b
--- /dev/null
+++ b/dev-python/wsgiintercept/wsgiintercept-0.6.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.5.ebuild,v 1.1 2014/07/01 06:35:58 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="wsgi_intercept"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI application in place of a real URI for testing"
+HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://github.com/cdent/python3-wsgi-intercept"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}