summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-03-26 03:23:52 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-03-26 03:23:52 +0000
commit554428746064cb88f2ad03456539f8012389120f (patch)
tree6d82b34769641c71660c10535eed7c39b65c402c /dev-python/wxpython
parentUpdate changelog as repoman didn't for some reason (diff)
downloadgentoo-2-554428746064cb88f2ad03456539f8012389120f.tar.gz
gentoo-2-554428746064cb88f2ad03456539f8012389120f.tar.bz2
gentoo-2-554428746064cb88f2ad03456539f8012389120f.zip
Prevent build system from considering preserved libs when checking wxGTK
features. (bug #376339). (Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog8
-rw-r--r--dev-python/wxpython/files/wxpython-2.8-no-preservatives-added.patch16
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild3
-rw-r--r--dev-python/wxpython/wxpython-2.9.3.1.ebuild5
-rw-r--r--dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild3
5 files changed, 30 insertions, 5 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index ea3a541d0ea8..22a796d6f027 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/wxpython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.177 2013/03/19 06:41:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.178 2013/03/26 03:23:52 dirtyepic Exp $
+
+ 26 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.8.12.1-r1.ebuild,
+ +files/wxpython-2.8-no-preservatives-added.patch, wxpython-2.9.3.1.ebuild,
+ wxpython-2.9.4.1-r1.ebuild:
+ Prevent build system from considering preserved libs when checking wxGTK
+ features. (bug #376339).
19 Mar 2013; Michał Górny <mgorny@gentoo.org> wxpython-2.8.12.1-r1.ebuild,
wxpython-2.9.4.1-r1.ebuild:
diff --git a/dev-python/wxpython/files/wxpython-2.8-no-preservatives-added.patch b/dev-python/wxpython/files/wxpython-2.8-no-preservatives-added.patch
new file mode 100644
index 000000000000..5e4221d51506
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8-no-preservatives-added.patch
@@ -0,0 +1,16 @@
+Portage preserve-libs removes the linker name (.so) of a library but leaves
+the soname (.so.4) and realname (.so.4.0) installed. findLib searches for
+mywxlibname.* and returns true if anything is found. Disaster ensues.
+
+
+--- a/wxPython/config.py
++++ b/wxPython/config.py
+@@ -612,7 +612,7 @@ def findLib(name, libdirs):
+ dirs = libdirs[:]
+ for d in dirs:
+ p = os.path.join(d, name)
+- if glob.glob(p+'*') != []:
++ if glob.glob(p+'*.so') != []:
+ return True
+ return False
+
diff --git a/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
index 85f04f8c3206..4480cffef6ac 100644
--- a/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild,v 1.3 2013/03/19 06:41:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild,v 1.4 2013/03/26 03:23:52 dirtyepic Exp $
EAPI=5
@@ -65,6 +65,7 @@ python_prepare_all() {
# drop editra - we have it as a separate package now
"${FILESDIR}"/${PN}-2.8.12-drop-editra.patch
"${FILESDIR}"/${PN}-2.8.12-drop-categories.patch
+ "${FILESDIR}"/${PN}-2.8-no-preservatives-added.patch
)
distutils-r1_python_prepare_all
diff --git a/dev-python/wxpython/wxpython-2.9.3.1.ebuild b/dev-python/wxpython/wxpython-2.9.3.1.ebuild
index 79e4ab7ba233..0e7f0deafb5f 100644
--- a/dev-python/wxpython/wxpython-2.9.3.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.9.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.3.1.ebuild,v 1.5 2012/09/05 09:36:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.3.1.ebuild,v 1.6 2013/03/26 03:23:52 dirtyepic Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@@ -51,6 +51,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-${SLOT}-wxversion-scripts.patch
# drop editra - we have it as a separate package now
epatch "${FILESDIR}"/${PN}-2.8.11-drop-editra.patch
+ epatch "${FILESDIR}"/${PN}-2.8-no-preservatives-added.patch
if use examples; then
cd "${DOC_S}"
diff --git a/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild b/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild
index a8948d6f07d1..bdcd9c8e7d8b 100644
--- a/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild,v 1.2 2013/03/19 06:41:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild,v 1.3 2013/03/26 03:23:52 dirtyepic Exp $
EAPI=5
@@ -60,6 +60,7 @@ python_prepare_all() {
"${FILESDIR}"/${P}-wxversion-scripts.patch
# drop editra - we have it as a separate package now
"${FILESDIR}"/${PN}-2.8.11-drop-editra.patch
+ "${FILESDIR}"/${PN}-2.8-no-preservatives-added.patch
)
distutils-r1_python_prepare_all