summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 19:00:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 19:00:20 +0000
commit237ed7657ef0aaf097d02e5e90621e2575c97c53 (patch)
tree73c873c5bd69398861a660d95ce19b9c90db6c3b /dev-python/zsi
parentFixing bug #335680 (diff)
downloadgentoo-2-237ed7657ef0aaf097d02e5e90621e2575c97c53.tar.gz
gentoo-2-237ed7657ef0aaf097d02e5e90621e2575c97c53.tar.bz2
gentoo-2-237ed7657ef0aaf097d02e5e90621e2575c97c53.zip
Update EAPI. Call python_pkg_setup().
(Portage version: 2.2_rc91_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/zsi')
-rw-r--r--dev-python/zsi/ChangeLog6
-rw-r--r--dev-python/zsi/zsi-2.0.ebuild17
-rw-r--r--dev-python/zsi/zsi-2.1_alpha1.ebuild14
3 files changed, 21 insertions, 16 deletions
diff --git a/dev-python/zsi/ChangeLog b/dev-python/zsi/ChangeLog
index ad1ee44867ea..2141d2ce23b3 100644
--- a/dev-python/zsi/ChangeLog
+++ b/dev-python/zsi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/zsi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/ChangeLog,v 1.12 2010/05/25 21:01:39 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/ChangeLog,v 1.13 2010/10/10 19:00:20 arfrever Exp $
+
+ 10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ zsi-2.0.ebuild, zsi-2.1_alpha1.ebuild:
+ Update EAPI. Call python_pkg_setup().
25 May 2010; Christoph Mende <angelos@gentoo.org> zsi-2.0.ebuild,
zsi-2.1_alpha1.ebuild:
diff --git a/dev-python/zsi/zsi-2.0.ebuild b/dev-python/zsi/zsi-2.0.ebuild
index aef44578f533..8e5f768f5254 100644
--- a/dev-python/zsi/zsi-2.0.ebuild
+++ b/dev-python/zsi/zsi-2.0.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/zsi-2.0.ebuild,v 1.9 2010/05/25 21:01:39 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/zsi-2.0.ebuild,v 1.10 2010/10/10 19:00:20 arfrever Exp $
+EAPI="3"
PYTHON_DEPEND="2:2.4"
inherit distutils
@@ -26,17 +27,15 @@ DEPEND=">=dev-python/pyxml-0.8.3
>=dev-lang/python-2.4 )"
S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME=${MY_PN}
+PYTHON_MODNAME="${MY_PN}"
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use twisted ; then
+src_prepare() {
+ if ! use twisted; then
sed -i \
-e "/version_info/d"\
-e "/ZSI.twisted/d"\
@@ -47,11 +46,11 @@ src_unpack() {
src_install() {
distutils_src_install
- if use doc ; then
+ if use doc; then
dohtml doc/*.html doc/*.css doc/*.png
fi
- if use examples ; then
+ if use examples; then
insinto /usr/share/doc/${PF}/examples
doins -r doc/examples/* samples/*
fi
diff --git a/dev-python/zsi/zsi-2.1_alpha1.ebuild b/dev-python/zsi/zsi-2.1_alpha1.ebuild
index af29e53b9217..c47a736916c9 100644
--- a/dev-python/zsi/zsi-2.1_alpha1.ebuild
+++ b/dev-python/zsi/zsi-2.1_alpha1.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/zsi-2.1_alpha1.ebuild,v 1.3 2010/05/25 21:01:39 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/zsi-2.1_alpha1.ebuild,v 1.4 2010/10/10 19:00:20 arfrever Exp $
-EAPI=2
+EAPI="3"
PYTHON_DEPEND="2:2.4"
+
inherit distutils
-MY_PN=ZSI
-MY_P=${MY_PN}-${PV/_alpha/-a}
+MY_PN="ZSI"
+MY_P="${MY_PN}-${PV/_alpha/-a}"
DESCRIPTION="Web Services for Python"
HOMEPAGE="http://pywebsvcs.sourceforge.net/zsi.html"
@@ -23,11 +24,12 @@ DEPEND=">=dev-python/pyxml-0.8.3
twisted? ( >=dev-python/twisted-2
>=dev-python/twisted-web-0.5 )"
-S=${WORKDIR}/${MY_P}
-PYTHON_MODNAME=${MY_PN}
+S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="${MY_PN}"
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {