summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-04-28 02:39:35 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-04-28 02:39:35 +0000
commit08cbe6c39272a04018057c334cde60201dd1145e (patch)
treec3140c918f1b79fee6861c39c87c7d74f5795984 /dev-python
parentFix description (diff)
downloadgentoo-2-08cbe6c39272a04018057c334cde60201dd1145e.tar.gz
gentoo-2-08cbe6c39272a04018057c334cde60201dd1145e.tar.bz2
gentoo-2-08cbe6c39272a04018057c334cde60201dd1145e.zip
more fucking shit
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/taskflow/ChangeLog7
-rw-r--r--dev-python/taskflow/taskflow-0.1.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/taskflow/ChangeLog b/dev-python/taskflow/ChangeLog
index d0c0aa2a2ac8..707d5a710571 100644
--- a/dev-python/taskflow/ChangeLog
+++ b/dev-python/taskflow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/taskflow
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/taskflow/ChangeLog,v 1.1 2014/04/28 02:26:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/taskflow/ChangeLog,v 1.2 2014/04/28 02:39:35 prometheanfire Exp $
+
+*taskflow-0.1.3 (28 Apr 2014)
+
+ 28 Apr 2014; Matthew Thode <prometheanfire@gentoo.org> +taskflow-0.1.3.ebuild:
+ more fucking shit
*taskflow-0.2 (28 Apr 2014)
diff --git a/dev-python/taskflow/taskflow-0.1.3.ebuild b/dev-python/taskflow/taskflow-0.1.3.ebuild
new file mode 100644
index 000000000000..60ed5c263488
--- /dev/null
+++ b/dev-python/taskflow/taskflow-0.1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/taskflow/taskflow-0.1.3.ebuild,v 1.1 2014/04/28 02:39:35 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+#not dealing with yet another dep
+RESTRICT="test"
+
+DESCRIPTION="A library to do [jobs, tasks, flows] in a HA manner using different backends"
+HOMEPAGE="https://github.com/openstack/taskflow"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/keyring-2.1[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.8[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.14[${PYTHON_USEDEP}]
+ >=dev-python/futures-2.1.3[${PYTHON_USEDEP}]"
+
+python_test() {
+ testr init
+ testr run --parallel || die "testsuite failed under python2.7"
+}