summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2005-10-30 05:03:46 +0000
committerChris PeBenito <pebenito@gentoo.org>2005-10-30 05:03:46 +0000
commit0cdbb2805f9375536329583cac498ab37a583267 (patch)
treed680c82ad58e308ad6089191d853fa5065b2141f /dev-python
parentInitial import. Thanks to iso, kobayashi and aisomur for the help at http://e... (diff)
downloadgentoo-2-0cdbb2805f9375536329583cac498ab37a583267.tar.gz
gentoo-2-0cdbb2805f9375536329583cac498ab37a583267.tar.bz2
gentoo-2-0cdbb2805f9375536329583cac498ab37a583267.zip
new release
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-selinux/ChangeLog8
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.160
-rw-r--r--dev-python/python-selinux/files/python-selinux-2.16.c.bz2bin0 -> 8500 bytes
-rw-r--r--dev-python/python-selinux/python-selinux-2.16.ebuild36
4 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index 3f25e9037195..4e6fa7a9333f 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.24 2005/05/10 18:33:41 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.25 2005/10/30 05:03:46 pebenito Exp $
+
+*python-selinux-2.16 (30 Oct 2005)
+
+ 30 Oct 2005; Chris PeBenito <pebenito@gentoo.org>
+ +files/python-selinux-2.16.c.bz2, +python-selinux-2.16.ebuild:
+ Overhaul error handling and SELinux-enable handling.
10 May 2005; Stephen Bennett <spb@gentoo.org> python-selinux-2.15.ebuild:
mips stable
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.16 b/dev-python/python-selinux/files/digest-python-selinux-2.16
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-2.16
diff --git a/dev-python/python-selinux/files/python-selinux-2.16.c.bz2 b/dev-python/python-selinux/files/python-selinux-2.16.c.bz2
new file mode 100644
index 000000000000..65467ca0c868
--- /dev/null
+++ b/dev-python/python-selinux/files/python-selinux-2.16.c.bz2
Binary files differ
diff --git a/dev-python/python-selinux/python-selinux-2.16.ebuild b/dev-python/python-selinux/python-selinux-2.16.ebuild
new file mode 100644
index 000000000000..7bdec977a0d9
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-2.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16.ebuild,v 1.1 2005/10/30 05:03:46 pebenito Exp $
+
+inherit python
+python_version
+
+DESCRIPTION="Python bindings for SELinux functions"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+LICENSE="GPL-2"
+SLOT="0"
+
+#KEYWORDS="x86 ppc sparc amd64 mips"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~mips"
+IUSE=""
+
+DEPEND="dev-lang/python
+ sys-libs/libselinux"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir -p ${S}
+ bzcat ${FILESDIR}/${P}.c.bz2 > ${S}/selinux.c || die
+}
+
+src_compile() {
+ cd ${S}
+ einfo "Compiling selinux.so for python ${PYVER}"
+ gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
+}
+
+src_install() {
+ insinto /usr/lib/python${PYVER}/site-packages
+ doins selinux.so
+}