summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2006-08-23 18:57:43 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2006-08-23 18:57:43 +0000
commit0cf1bcffd01bf8b27b25bfca5bc04ae1ab1f68a6 (patch)
treed7c66a35260cdaf7cbe440fb31ec7cd3fed90d9a /dev-python
parentversion bump (diff)
downloadgentoo-2-0cf1bcffd01bf8b27b25bfca5bc04ae1ab1f68a6.tar.gz
gentoo-2-0cf1bcffd01bf8b27b25bfca5bc04ae1ab1f68a6.tar.bz2
gentoo-2-0cf1bcffd01bf8b27b25bfca5bc04ae1ab1f68a6.zip
Version bump. Added patch to disable support for setuptools.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urwid/ChangeLog8
-rw-r--r--dev-python/urwid/files/digest-urwid-0.9.63
-rw-r--r--dev-python/urwid/files/urwid-0.9.6-nosetuptools.diff14
-rw-r--r--dev-python/urwid/urwid-0.9.6.ebuild37
4 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 8443bd61e12e..447e67d2aafb 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.15 2006/07/17 07:45:45 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.16 2006/08/23 18:57:43 lucass Exp $
+
+*urwid-0.9.6 (23 Aug 2006)
+
+ 23 Aug 2006; Lukasz Strzygowski <lucass@gentoo.org>
+ +files/urwid-0.9.6-nosetuptools.diff, +urwid-0.9.6.ebuild:
+ Version bump. Added patch to disable support for setuptools.
17 Jul 2006; Lukasz Strzygowski <lucass@gentoo.org>
-files/urwid-0.8.7-input.diff, -urwid-0.8.6.ebuild,
diff --git a/dev-python/urwid/files/digest-urwid-0.9.6 b/dev-python/urwid/files/digest-urwid-0.9.6
new file mode 100644
index 000000000000..4e6d1429511e
--- /dev/null
+++ b/dev-python/urwid/files/digest-urwid-0.9.6
@@ -0,0 +1,3 @@
+MD5 f6fd4fe98ec9a321ebb5ccc5387564a0 urwid-0.9.6.tar.gz 143608
+RMD160 a74fc92b790dea364f0541bb4f4e4dfcf6772079 urwid-0.9.6.tar.gz 143608
+SHA256 ec6d37df2f8b0f19557fe39327ac0a3181c5e46a1e448da9e25a813617f1771f urwid-0.9.6.tar.gz 143608
diff --git a/dev-python/urwid/files/urwid-0.9.6-nosetuptools.diff b/dev-python/urwid/files/urwid-0.9.6-nosetuptools.diff
new file mode 100644
index 000000000000..4222262d998e
--- /dev/null
+++ b/dev-python/urwid/files/urwid-0.9.6-nosetuptools.diff
@@ -0,0 +1,14 @@
+--- setup.py.orig 2006-08-23 20:49:39.000000000 +0200
++++ setup.py 2006-08-23 20:49:50.000000000 +0200
+@@ -19,10 +19,7 @@
+ #
+ # Urwid web site: http://excess.org/urwid/
+
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
++from distutils.core import setup
+
+ import os
+
diff --git a/dev-python/urwid/urwid-0.9.6.ebuild b/dev-python/urwid/urwid-0.9.6.ebuild
new file mode 100644
index 000000000000..1d81eb921291
--- /dev/null
+++ b/dev-python/urwid/urwid-0.9.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.6.ebuild,v 1.1 2006/08/23 18:57:43 lucass Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="examples"
+DEPEND="virtual/python"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-nosetuptools.diff"
+}
+
+src_test() {
+ ${python} test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins browse.py calc.py dialog.py edit.py
+ doins fib.py graph.py input_test.py tour.py
+ fi
+}