summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-13 01:06:58 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-13 01:06:58 +0000
commit2672158115b0138c49f8e5477ac80862c79c9a7d (patch)
tree25eeb5e83686368ec924df227857ec41f87ffe29 /dev-python
parentversion bump (diff)
downloadgentoo-2-2672158115b0138c49f8e5477ac80862c79c9a7d.tar.gz
gentoo-2-2672158115b0138c49f8e5477ac80862c79c9a7d.tar.bz2
gentoo-2-2672158115b0138c49f8e5477ac80862c79c9a7d.zip
clean old impls, add py3, restrict tests to save display of erroneous failures
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astng/ChangeLog5
-rw-r--r--dev-python/astng/astng-0.24.3.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/astng/ChangeLog b/dev-python/astng/ChangeLog
index 432f1a979e15..f29cf34b2b15 100644
--- a/dev-python/astng/ChangeLog
+++ b/dev-python/astng/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/astng
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.75 2014/08/03 10:20:37 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.76 2014/12/13 01:06:58 idella4 Exp $
+
+ 13 Dec 2014; Ian Delaney <idella4@gentoo.org> astng-0.24.3.ebuild:
+ clean old impls, add py3, restrict tests to save display of erroneous failures
03 Aug 2014; Michał Górny <mgorny@gentoo.org> astng-0.24.3.ebuild:
Fix the test phase to install modules as files rather than binary egg as
diff --git a/dev-python/astng/astng-0.24.3.ebuild b/dev-python/astng/astng-0.24.3.ebuild
index 225cd34df002..86ffcbc55294 100644
--- a/dev-python/astng/astng-0.24.3.ebuild
+++ b/dev-python/astng/astng-0.24.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.24.3.ebuild,v 1.7 2014/08/03 10:20:37 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.24.3.ebuild,v 1.8 2014/12/13 01:06:58 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -24,6 +24,7 @@ DEPEND="${RDEPEND}
test? ( >=dev-python/egenix-mx-base-3.0.0[$(python_gen_usedep 'python2*')] )"
S="${WORKDIR}/logilab-${P}"
+RESTRICT="test" # erroneous failures
# a wit; pypy reports astng modules differently
PATCHES=( "${FILESDIR}"/pypy-test.patch )