summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Balistreri <brain@gentoo.org>2003-04-29 11:21:36 +0000
committerMichele Balistreri <brain@gentoo.org>2003-04-29 11:21:36 +0000
commit34520df1a5c2fd6c9e693f09de23bd6b9d9c075c (patch)
tree66b41317588ea11a84ca885e992491fe17ef880e /dev-python
parentFixed apache dependency to depend on at least 2.0.45 (diff)
downloadgentoo-2-34520df1a5c2fd6c9e693f09de23bd6b9d9c075c.tar.gz
gentoo-2-34520df1a5c2fd6c9e693f09de23bd6b9d9c075c.tar.bz2
gentoo-2-34520df1a5c2fd6c9e693f09de23bd6b9d9c075c.zip
Version bump
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog8
-rw-r--r--dev-python/PyQt/Manifest9
-rw-r--r--dev-python/PyQt/PyQt-3.6.ebuild50
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.61
-rw-r--r--dev-python/PyQt/files/license-3.6.diff34
5 files changed, 97 insertions, 5 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 879045e73837..5cf274567acf 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.15 2003/04/17 12:55:49 brain Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.16 2003/04/29 11:21:06 brain Exp $
+
+*PyQt-3.6 (29 Apr 2003)
+ 29 Apr 2003; Michele Balistreri <brain@gentoo.org> PyQt-3.6.ebuild :
+ Version bump
+
17 Apr 2003; Michele Balistreri <brain@gentoo.org> Changelog :
Added IUSE flag for policy compliance
diff --git a/dev-python/PyQt/Manifest b/dev-python/PyQt/Manifest
index 7972ea688382..3f4a3e6905a0 100644
--- a/dev-python/PyQt/Manifest
+++ b/dev-python/PyQt/Manifest
@@ -1,7 +1,10 @@
-MD5 44eb7dbfe57434fb51f55a032492fdb8 ChangeLog 2067
-MD5 fbcf9e940591872c0e217613db07a2d9 PyQt-3.5.ebuild 1179
+MD5 778990cfc4aa16f6483a0eb77af0c832 ChangeLog 2176
+MD5 85a96fe8a5d3556a99da85a5151a6f8f PyQt-3.6.ebuild 1424
MD5 391f28d02fadbc5276d09fec5c28798c PyQt-3.5-r1.ebuild 1377
+MD5 fbcf9e940591872c0e217613db07a2d9 PyQt-3.5.ebuild 1179
+MD5 37aecdea8b6915ebc7f7e558aa0efbf9 files/license-3.6.diff 984
+MD5 02f19a3e9665543de676bb8eed138769 files/digest-PyQt-3.6 68
MD5 cfa5b5c9a44fc587bc3937b2d1335bb9 files/digest-PyQt-3.5 68
-MD5 ac2fc9d166ddfb0637781545e6d168c0 files/license-3.5.diff 972
MD5 cfa5b5c9a44fc587bc3937b2d1335bb9 files/digest-PyQt-3.5-r1 68
MD5 94164eef52f16b805d3c252c02100d11 files/qt3.1.2-compilation-fix-3.5.diff 2151
+MD5 ac2fc9d166ddfb0637781545e6d168c0 files/license-3.5.diff 972
diff --git a/dev-python/PyQt/PyQt-3.6.ebuild b/dev-python/PyQt/PyQt-3.6.ebuild
new file mode 100644
index 000000000000..a22cb0ba0df9
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.6.ebuild,v 1.1 2003/04/29 11:21:06 brain Exp $
+
+inherit eutils distutils
+
+IUSE=""
+S="${WORKDIR}/PyQt-x11-gpl-${PV}"
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ >=x11-libs/qt-3.0.4.1
+ >=dev-lang/python-2.2.1
+ =dev-python/sip-${PV}"
+
+src_unpack() {
+ unpack PyQt-x11-gpl-${PV}.tar.gz
+ cd ${S}
+ epatch $FILESDIR/license-${PV}.diff
+}
+
+src_compile() {
+
+ distutils_python_version
+ # standard qt sandbox problem workaround
+ [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
+ dodir /usr/lib/python${PYVER}/site-packages
+ dodir /usr/include/python${PYVER}
+ python build.py \
+ -d ${D}/usr/lib/python${PYVER}/site-packages \
+ -e /usr/include/python${PYVER} \
+ -b ${D}/usr/bin \
+ -l qt-mt -c
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README.Linux NEWS LICENSE README ChangeLog THANKS
+ dodir /usr/share/doc/${P}/
+ mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
+ # I found out this location from the redhat rpm
+ insinto /usr/share/sip/qt
+ doins ${S}/sip/*
+}
diff --git a/dev-python/PyQt/files/digest-PyQt-3.6 b/dev-python/PyQt/files/digest-PyQt-3.6
new file mode 100644
index 000000000000..2a8a3902ef0c
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.6
@@ -0,0 +1 @@
+MD5 bedea8fb28940471c86699e6656452e5 PyQt-x11-gpl-3.6.tar.gz 666276
diff --git a/dev-python/PyQt/files/license-3.6.diff b/dev-python/PyQt/files/license-3.6.diff
new file mode 100644
index 000000000000..427004c485fb
--- /dev/null
+++ b/dev-python/PyQt/files/license-3.6.diff
@@ -0,0 +1,34 @@
+--- build.py.orig 2003-04-26 17:28:46.000000000 +0200
++++ build.py 2003-04-29 11:41:49.000000000 +0200
+@@ -685,31 +685,6 @@
+ licType = "GPL"
+ licname = "GNU General Public License"
+
+- inform("This is the %s version of PyQt and is licensed under the %s." % (licType,licname),0)
+-
+- print
+- print "Type 'L' to view the license."
+- print "Type 'yes' to accept the terms of the license."
+- print "Type 'no' to decline the terms of the license."
+- print
+-
+- while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except:
+- resp = ""
+-
+- resp = string.lower(string.strip(resp))
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(0)
+-
+- if resp == "l":
+- os.system("more LICENSE")
+-
+ inform("Building the %s version of PyQt 3.6 for Python %s on %s." % (licType,pyFullVers,sys.platform))
+
+ if licType != "GPL":