summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 00:42:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 00:42:09 +0000
commit3a8c751fa6374eabccf492a2fc49aab08c6108a3 (patch)
tree0222ba57e3d691574ddaecf7048320a2c16b85de /dev-python
parentDelete older ebuild. (diff)
downloadgentoo-2-3a8c751fa6374eabccf492a2fc49aab08c6108a3.tar.gz
gentoo-2-3a8c751fa6374eabccf492a2fc49aab08c6108a3.tar.bz2
gentoo-2-3a8c751fa6374eabccf492a2fc49aab08c6108a3.zip
Version bump.
(Portage version: 2.2.0_alpha19_p14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/codetools/ChangeLog10
-rw-r--r--dev-python/codetools/codetools-3.2.0.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/dev-python/codetools/ChangeLog b/dev-python/codetools/ChangeLog
index c4a90b9cd6ee..d47af6db5d35 100644
--- a/dev-python/codetools/ChangeLog
+++ b/dev-python/codetools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/codetools
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/codetools/ChangeLog,v 1.7 2010/10/18 13:08:58 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/codetools/ChangeLog,v 1.8 2011/01/30 00:42:09 arfrever Exp $
+
+*codetools-3.2.0 (30 Jan 2011)
+
+ 30 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -codetools-3.1.2.ebuild, +codetools-3.2.0.ebuild:
+ Version bump.
*codetools-3.1.2 (18 Oct 2010)
diff --git a/dev-python/codetools/codetools-3.2.0.ebuild b/dev-python/codetools/codetools-3.2.0.ebuild
new file mode 100644
index 000000000000..83ce31102987
--- /dev/null
+++ b/dev-python/codetools/codetools-3.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/codetools/codetools-3.2.0.ebuild,v 1.1 2011/01/30 00:42:09 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="CodeTools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Enthought Tool Suite: Code analysis and execution tools"
+HOMEPAGE="http://code.enthought.com/projects/code_tools/ http://pypi.python.org/pypi/CodeTools"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+IUSE="doc examples test"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+RDEPEND="dev-python/numpy
+ >=dev-python/traits-3.6.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/nose )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="enthought"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ find -name "*LICENSE.txt" -delete
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}