summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-30 06:19:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-30 06:19:36 +0000
commit3bff2e5037f312651a46e3ccd9f0563ecc7fd66c (patch)
tree462b82fa67a3669a4f6c79d2a273e15c672e2474 /dev-python
parentBump (diff)
downloadgentoo-2-3bff2e5037f312651a46e3ccd9f0563ecc7fd66c.tar.gz
gentoo-2-3bff2e5037f312651a46e3ccd9f0563ecc7fd66c.tar.bz2
gentoo-2-3bff2e5037f312651a46e3ccd9f0563ecc7fd66c.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/icalendar/ChangeLog8
-rw-r--r--dev-python/icalendar/icalendar-3.1.ebuild40
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-python/icalendar/ChangeLog b/dev-python/icalendar/ChangeLog
index a3f44e7b690e..1a56a48df922 100644
--- a/dev-python/icalendar/ChangeLog
+++ b/dev-python/icalendar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/icalendar
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.18 2012/03/09 10:32:19 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.19 2012/10/30 06:19:36 patrick Exp $
+
+*icalendar-3.1 (30 Oct 2012)
+
+ 30 Oct 2012; Patrick Lauer <patrick@gentoo.org> +icalendar-3.1.ebuild:
+ Bump
09 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> icalendar-2.2.ebuild:
x86 stable wrt bug #400327
@@ -98,4 +103,3 @@
04 Jul 2009; Joe Sapp <nixphoeni@gentoo.org> +icalendar-2.0.1.ebuild,
+files/icalendar-2.0.1-UIDGenerator-fix.patch, +metadata.xml:
Initial commit - bug #111822
-
diff --git a/dev-python/icalendar/icalendar-3.1.ebuild b/dev-python/icalendar/icalendar-3.1.ebuild
new file mode 100644
index 000000000000..3a3d99a2423d
--- /dev/null
+++ b/dev-python/icalendar/icalendar-3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.1.ebuild,v 1.1 2012/10/30 06:19:36 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+MY_PN="collective-${PN}"
+S="${WORKDIR}/${MY_PN}-8538879"
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)."
+HOMEPAGE="http://github.com/collective/icalendar"
+SRC_URI="http://github.com/collective/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc"
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="TODO.txt"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd docs
+ emake text || die "building documentation"
+ DOCS="${DOCS} docs/_build/text/*.txt"
+ fi
+}