summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-04-26 20:01:53 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-04-26 20:01:53 +0000
commit49c4c36a1d60ed7a4c150db41c98c3a21f9f03dd (patch)
treef12b02c090133d0bfabb08d395beea70ce8c445f /dev-python
parentAdd die following econf for bug 48950 (Manifest recommit) (diff)
downloadgentoo-2-49c4c36a1d60ed7a4c150db41c98c3a21f9f03dd.tar.gz
gentoo-2-49c4c36a1d60ed7a4c150db41c98c3a21f9f03dd.tar.bz2
gentoo-2-49c4c36a1d60ed7a4c150db41c98c3a21f9f03dd.zip
add getcon and setexec functions
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-selinux/ChangeLog8
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.130
-rw-r--r--dev-python/python-selinux/files/python-selinux-2.13.c.bz2bin0 -> 5882 bytes
-rw-r--r--dev-python/python-selinux/python-selinux-2.13.ebuild36
4 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index e290aaec5a3f..cbc78e1d399f 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.16 2004/04/08 19:21:28 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.17 2004/04/26 20:01:53 pebenito Exp $
+
+*python-selinux-2.13 (26 Apr 2004)
+
+ 26 Apr 2004; Chris PeBenito <pebenito@gentoo.org>
+ +python-selinux-2.13.ebuild:
+ Add getcon and setexec functions.
08 Apr 2004; Chris PeBenito <pebenito@gentoo.org>
python-selinux-2.12.ebuild:
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.13 b/dev-python/python-selinux/files/digest-python-selinux-2.13
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-2.13
diff --git a/dev-python/python-selinux/files/python-selinux-2.13.c.bz2 b/dev-python/python-selinux/files/python-selinux-2.13.c.bz2
new file mode 100644
index 000000000000..47493667e5b0
--- /dev/null
+++ b/dev-python/python-selinux/files/python-selinux-2.13.c.bz2
Binary files differ
diff --git a/dev-python/python-selinux/python-selinux-2.13.ebuild b/dev-python/python-selinux/python-selinux-2.13.ebuild
new file mode 100644
index 000000000000..15b29abf9467
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-2.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.13.ebuild,v 1.1 2004/04/26 20:01:53 pebenito Exp $
+
+inherit python
+python_version
+
+DESCRIPTION="Python bindings for SELinux functions"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+DEPEND="dev-lang/python
+ sys-libs/libselinux"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir -p ${S}
+ bzcat ${FILESDIR}/${P}.c.bz2 > ${S}/selinux.c
+}
+
+src_compile() {
+ cd ${S}
+ einfo "Compiling selinux.so for python ${PYVER}"
+ gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
+}
+
+src_install() {
+ insinto /usr/lib/python${PYVER}/site-packages
+ doins selinux.so
+}