summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-20 14:22:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-20 14:22:51 +0000
commit5045133966cfbb8de64ec40144982248362e5cca (patch)
treedda151fa96fcc12f1ee54a64825c322de5d717d5 /dev-python
parentamd64 stable wrt security bug 263711 (diff)
downloadgentoo-2-5045133966cfbb8de64ec40144982248362e5cca.tar.gz
gentoo-2-5045133966cfbb8de64ec40144982248362e5cca.tar.bz2
gentoo-2-5045133966cfbb8de64ec40144982248362e5cca.zip
Don't install modules specific for other versions of Python (bug #274499).
(Portage version: 13655-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/ChangeLog6
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.1.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 127d809259c8..53eedc7d0134 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.65 2009/06/16 17:52:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.66 2009/06/20 14:22:51 arfrever Exp $
+
+ 20 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ PyQt4-4.5.1.ebuild:
+ Don't install modules specific for other versions of Python (bug #274499).
16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.5.1.ebuild:
Raise sip dependency to 4.8.1
diff --git a/dev-python/PyQt4/PyQt4-4.5.1.ebuild b/dev-python/PyQt4/PyQt4-4.5.1.ebuild
index 5de27d7a886d..47b7f5c9ab1a 100644
--- a/dev-python/PyQt4/PyQt4-4.5.1.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.5.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.1.ebuild,v 1.2 2009/06/16 17:52:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.1.ebuild,v 1.3 2009/06/20 14:22:51 arfrever Exp $
EAPI="2"
-inherit distutils qt4
+inherit distutils python qt4
MY_P=PyQt-x11-gpl-${PV}
QTVER="4.5.1"
@@ -56,6 +56,14 @@ src_prepare() {
"${S}"/configure.py || die
fi
qt4_src_prepare
+
+ # Remove this code after removing Python 2 from the tree.
+ python_version
+ if [[ "${PYVER:0:1}" == "3" ]]; then
+ rm -fr pyuic/uic/port_v2
+ else
+ rm -fr pyuic/uic/port_v3
+ fi
}
src_configure() {