summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-04-22 19:39:46 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-04-22 19:39:46 +0000
commit51c7ed3294bd2ecc74884444f261fa7cec16c463 (patch)
tree9dea7053695715d04a1b123bc1e27b4568704f42 /dev-python
parentbup (diff)
downloadgentoo-2-51c7ed3294bd2ecc74884444f261fa7cec16c463.tar.gz
gentoo-2-51c7ed3294bd2ecc74884444f261fa7cec16c463.tar.bz2
gentoo-2-51c7ed3294bd2ecc74884444f261fa7cec16c463.zip
bup
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/stevedore/ChangeLog8
-rw-r--r--dev-python/stevedore/stevedore-1.4.0.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/stevedore/ChangeLog b/dev-python/stevedore/ChangeLog
index 76d673a84d35..c9c4ff11ffb3 100644
--- a/dev-python/stevedore/ChangeLog
+++ b/dev-python/stevedore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/stevedore
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.29 2015/04/08 08:05:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.30 2015/04/22 19:39:46 prometheanfire Exp $
+
+*stevedore-1.4.0 (22 Apr 2015)
+
+ 22 Apr 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +stevedore-1.4.0.ebuild:
+ bup
08 Apr 2015; Michał Górny <mgorny@gentoo.org> stevedore-0.15.ebuild:
Drop old Python implementations
diff --git a/dev-python/stevedore/stevedore-1.4.0.ebuild b/dev-python/stevedore/stevedore-1.4.0.ebuild
new file mode 100644
index 000000000000..66bc62c22683
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-1.4.0.ebuild,v 1.1 2015/04/22 19:39:46 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.python.org/pypi/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && ${EPYTHON} setup.py build_sphinx
+}
+
+python_test() {
+ nosetests stevedore || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}