summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-05 08:16:24 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-05 08:16:24 +0000
commit6535e73eef3c562fad8f9d1786510398bcbccd7f (patch)
tree88967ec3d346d8c1291c460bdcb406bdb00c0e3c /dev-python
parentControl quorum via USE=tls since it also relies on gnutls. (diff)
downloadgentoo-2-6535e73eef3c562fad8f9d1786510398bcbccd7f.tar.gz
gentoo-2-6535e73eef3c562fad8f9d1786510398bcbccd7f.tar.bz2
gentoo-2-6535e73eef3c562fad8f9d1786510398bcbccd7f.zip
drop py2.6 add py3.4 support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mpmath/ChangeLog5
-rw-r--r--dev-python/mpmath/mpmath-0.19.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index fa54423e8a84..e15f5659d697 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/mpmath
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.33 2014/07/22 17:47:20 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.34 2014/08/05 08:16:24 idella4 Exp $
+
+ 05 Aug 2014; Ian Delaney <idella4@gentoo.org> mpmath-0.19.ebuild:
+ drop py2.6 add py3.4 support
22 Jul 2014; Rick Farina <zerochaos@gentoo.org> mpmath-0.18.ebuild,
mpmath-0.19.ebuild:
diff --git a/dev-python/mpmath/mpmath-0.19.ebuild b/dev-python/mpmath/mpmath-0.19.ebuild
index 47c394fb2f64..c7c10b5602c7 100644
--- a/dev-python/mpmath/mpmath-0.19.ebuild
+++ b/dev-python/mpmath/mpmath-0.19.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.19.ebuild,v 1.2 2014/07/22 17:47:20 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.19.ebuild,v 1.3 2014/08/05 08:16:24 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit distutils-r1 eutils
@@ -23,7 +23,7 @@ IUSE="doc examples gmp matplotlib test"
RDEPEND="
gmp? ( dev-python/gmpy )
- matplotlib? ( dev-python/matplotlib )"
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"