summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 15:53:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 15:53:35 +0000
commit6a1df1a45a7d002dacd22a50d044998bfa7298a4 (patch)
treebe73c2c82e3d628b17b449451183d8c35cbf888c /dev-python
parentFix license. (diff)
downloadgentoo-2-6a1df1a45a7d002dacd22a50d044998bfa7298a4.tar.gz
gentoo-2-6a1df1a45a7d002dacd22a50d044998bfa7298a4.tar.bz2
gentoo-2-6a1df1a45a7d002dacd22a50d044998bfa7298a4.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14155-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog6
-rw-r--r--dev-python/pylint/pylint-0.18.0.ebuild58
2 files changed, 36 insertions, 28 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index d79d434b5678..7efc65a61d4a 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.48 2009/06/19 14:40:07 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.49 2009/08/25 15:53:35 arfrever Exp $
+
+ 25 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pylint-0.18.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*pylint-0.18.0 (19 Jun 2009)
diff --git a/dev-python/pylint/pylint-0.18.0.ebuild b/dev-python/pylint/pylint-0.18.0.ebuild
index 651127717877..683df6828695 100644
--- a/dev-python/pylint/pylint-0.18.0.ebuild
+++ b/dev-python/pylint/pylint-0.18.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.18.0.ebuild,v 1.2 2009/06/23 15:18:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.18.0.ebuild,v 1.3 2009/08/25 15:53:35 arfrever Exp $
EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit eutils distutils python
@@ -20,33 +21,36 @@ DEPEND=">=dev-python/logilab-common-0.38
RDEPEND="${DEPEND}
dev-lang/python[tk?]"
-src_test() {
- python_version
-
- local lpath="${T}/test/lib/python"
- local tpath=""
+RESTRICT_PYTHON_ABIS="3*"
- # Create testdir and copy pylint into it for testing purpose.
- mkdir -p "${lpath}/logilab" || die
- PYTHONPATH="${lpath}" ${python} setup.py install --home="${T}/test" \
- || die "test copy failed"
-
- # To support test w/o setuptools.
- if [[ -d "${lpath}/${PN}" ]]; then
- tpath="${lpath}/${PN}"
- else
- tpath="${lpath}/${P}-py${PYVER}.egg/${PN}"
- fi
-
- # Copy pylint unittest and logilab-{common,astng} into our temporary test
- # dir.
- cp -r test/ ${tpath} || die "copy tests failed"
- cp -r "$(python_get_sitedir)/logilab/"{common,astng} "${lpath}/logilab" \
- || die "copying logilab-{common,astng} failed!"
-
- pushd "${tpath}" >/dev/null || die
- PYTHONPATH="${lpath}" pytest -v || die "tests failed"
- popd >/dev/null || die
+src_test() {
+ testing() {
+ local lpath="${T}/test/lib/python"
+ local tpath=""
+
+ rm -fr "${lpath}"
+
+ # Create testdir and copy pylint into it for testing purpose.
+ mkdir -p "${lpath}/logilab" || die
+ PYTHONPATH="${lpath}" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home="${T}/test" || die "test copy failed"
+
+ # To support test w/o setuptools.
+ if [[ -d "${lpath}/${PN}" ]]; then
+ tpath="${lpath}/${PN}"
+ else
+ tpath="${lpath}/${P}-py${PYTHON_ABI}.egg/${PN}"
+ fi
+
+ # Copy pylint unittest and logilab-{common,astng} into our temporary test
+ # dir.
+ cp -r test/ ${tpath} || die "copy tests failed"
+ cp -r "$(python_get_sitedir)/logilab/"{common,astng} "${lpath}/logilab" || die "copying logilab-{common,astng} failed!"
+
+ pushd "${tpath}" >/dev/null || die
+ PYTHONPATH="${lpath}" pytest -v || die "tests failed"
+ popd >/dev/null || die
+ }
+ python_execute_function testing
}
src_install() {