summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-05-08 08:47:05 +0000
committerIan Delaney <idella4@gentoo.org>2015-05-08 08:47:05 +0000
commit74816dd5356a7fadacb6fd3ffed1671a48cca838 (patch)
tree487a6ab94ca48d319129411b114317ec2f3231f2 /dev-python
parentStable for amd64/x86, wrt bug #548612 (diff)
downloadgentoo-2-74816dd5356a7fadacb6fd3ffed1671a48cca838.tar.gz
gentoo-2-74816dd5356a7fadacb6fd3ffed1671a48cca838.tar.bz2
gentoo-2-74816dd5356a7fadacb6fd3ffed1671a48cca838.zip
bump one remove one, fixes bug #548588
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/celery/ChangeLog8
-rw-r--r--dev-python/celery/celery-3.1.18.ebuild (renamed from dev-python/celery/celery-3.1.16.ebuild)24
2 files changed, 19 insertions, 13 deletions
diff --git a/dev-python/celery/ChangeLog b/dev-python/celery/ChangeLog
index be24cd80edb3..26bb15a018f9 100644
--- a/dev-python/celery/ChangeLog
+++ b/dev-python/celery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/celery
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.48 2015/03/08 23:41:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.49 2015/05/08 08:47:05 idella4 Exp $
+
+*celery-3.1.18 (08 May 2015)
+
+ 08 May 2015; Ian Delaney <idella4@gentoo.org> +celery-3.1.18.ebuild,
+ -celery-3.1.16.ebuild:
+ bump one remove one, fixes bug #548588
08 Mar 2015; Pacho Ramos <pacho@gentoo.org> celery-3.1.17.ebuild:
x86 stable, bug 540290
diff --git a/dev-python/celery/celery-3.1.16.ebuild b/dev-python/celery/celery-3.1.18.ebuild
index 0606b6abf291..92ab9458d65d 100644
--- a/dev-python/celery/celery-3.1.16.ebuild
+++ b/dev-python/celery/celery-3.1.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.1.16.ebuild,v 1.2 2014/12/08 09:02:56 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.1.18.ebuild,v 1.1 2015/05/08 08:47:05 idella4 Exp $
EAPI=5
@@ -17,29 +17,31 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
# There are a number of other optional 'extras' which overlap with those of kombu, however
# there has been no apparent expression of interest or demand by users for them. See requires.txt
-IUSE="doc examples redis test"
+IUSE="doc examples redis sqs test yaml zeromq"
-PY2_USEDEP=$(python_gen_usedep python2_7)
+PY27_USEDEP=$(python_gen_usedep python2_7)
RDEPEND="<dev-python/kombu-3.1[${PYTHON_USEDEP}]
- >=dev-python/kombu-3.0.23[${PYTHON_USEDEP}]
+ >=dev-python/kombu-3.0.25[${PYTHON_USEDEP}]
>=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
- >=dev-python/billiard-3.3.0.18[${PYTHON_USEDEP}]
+ >=dev-python/billiard-3.3.0.20[${PYTHON_USEDEP}]
<dev-python/billiard-3.4[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/greenlet[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ sqs? ( >=dev-python/boto-2.13.3[${PY27_USEDEP}] )
+ zeromq? ( >=dev-python/pyzmq-13.1.0[${PYTHON_USEDEP}] )
+ yaml? ( >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )
test? ( ${RDEPEND}
- dev-python/gevent[${PY2_USEDEP}]
- >=dev-python/mock-1.0.1[${PY2_USEDEP}]
+ dev-python/gevent[${PY27_USEDEP}]
+ >=dev-python/mock-1.0.1[${PY27_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/nose-cover3[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
>=dev-python/pymongo-2.6.2[${PYTHON_USEDEP}]
redis? ( dev-python/redis-py[${PYTHON_USEDEP}]
>=dev-db/redis-2.8.0 )
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- )
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}] )
doc? (
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
@@ -61,8 +63,6 @@ python_compile_all() {
python_test() {
nosetests || die "Tests failed with ${EPYTHON}"
- # alternate method to run testsuite
- # esetup.py
}
python_install_all() {